程序设计基础65 STL之散列存储字符与二维vector的范围

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

一,关注点

1,要注意如何用hash方法表示字符串,尤其是掺杂字母和数字的,本题中处理最后一位数字的方法是ans=ans*10+str[3]-'0',注意是乘以10而不是26了。

2,二维定长vector的长度可达10^5,10^6可有望突破,故可以方便地表示散列,不用通过map映射一个很小的数字。

二,我的代码

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
const int max_n = 26 * 26 * 26 * 10 + 1;
//int arr[50000];
vector<int> vec[max_n];
int str_to_num(char str[]) {
	int ans = 0;
	for (int i = 0; i < 3; i++) {
		ans = ans * 26 + str[i] - 'A';
	}
	ans = ans * 10 + str[3] - '0';
	return ans;
}
bool cmp(int a, int b) {
	return a < b;
}
int main() {
	int N = 0, K = 0;
	char name[5];
	int temp = 0;
	scanf("%d %d", &N, &K);
	for (int i = 0; i < K; i++) {
		int id = 0, num = 0;
		scanf("%d %d", &id, &num);
		for (int i = 0; i < num; i++) {
			scanf("%s", name);
			temp = str_to_num(name);
			vec[temp].push_back(id);
		}
	}
	for (int i = 0; i < N; i++) {
		scanf("%s", name);
		int temp = str_to_num(name);
		sort(vec[temp].begin(), vec[temp].end(), cmp);
		printf("%s %d", name, vec[temp].size());
		for (int i = 0; i < vec[temp].size(); i++) {
			printf(" %d", vec[temp][i]);
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/84615037
今日推荐