程序设计基础74 链表之区分无效结点,删除结点与保留结点的方法

1097 Deduplication on a Linked List (25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

一,关注点

1,本题的关键在于如何区分标题上这三种结点,采用的是0+num_1,max_n+num_2,2*max_n的方法,然后计算出num_1+num_2即为除无效结点外的结点,通过一次sort排序轻易可得。当初我采用在struct中加了好几种标记的方法,繁琐又不轻易。

二,正确代码

#include<cstdio>
#include<algorithm>
using namespace std;
const int max_n = 100100;
bool isExist[max_n] = { false };
struct Node {
	int address, data, next;
	int order;
}node[max_n];
bool cmp(Node a, Node b) {
	return a.order < b.order;
}
int main() {
	int begin = 0, N = 0;
	int address = 0;
	for (int i = 0; i < max_n; i++) {
		node[i].order = 2 * max_n;
	}
	scanf("%d %d", &begin, &N);
	for (int i = 0; i < N; i++) {
		scanf("%d", &address);
		scanf("%d %d", &node[address].data, &node[address].next);
		node[address].address = address;
	}
	int Store = 0, Remove = 0, count = 0;
	int p = begin;
	while (p != -1) {
		if (isExist[abs(node[p].data)] == false) {
			isExist[abs(node[p].data)] = true;
			node[p].order = Store++;
		}
		else {
			node[p].order = max_n + Remove++;
		}
		p = node[p].next;
	}
	sort(node, node + max_n, cmp);
	count = Store + Remove;
	for (int i = 0; i < count; i++) {
		if (i != Store - 1 && i != count - 1) {
			printf("%05d %d %05d\n", node[i].address, node[i].data, node[i + 1].address);
		}
		else {
			printf("%05d %d -1\n", node[i].address, node[i].data);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/84726387