HDU-1873-看病要排队 (STL-queue)

版权声明:欢迎评论与转载,转载时请注明出处! https://blog.csdn.net/wjl_zyl_1314/article/details/84310819

原题链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1873
看病要排队这个是地球人都知道的常识。
不过经过细心的0068的观察,他发现了医院里排队还是有讲究的。0068所去的医院有三个医生(汗,这么少)同时看病。而看病的人病情有轻重,所以不能根据简单的先来先服务的原则。所以医院对每种病情规定了10种不同的优先级。级别为10的优先权最高,级别为1的优先权最低。医生在看病时,则会在他的队伍里面选择一个优先权最高的人进行诊治。如果遇到两个优先权一样的病人的话,则选择最早来排队的病人。

现在就请你帮助医院模拟这个看病过程。
Input
输入数据包含多组测试,请处理到文件结束。
每组数据第一行有一个正整数N(0<N<2000)表示发生事件的数目。
接下来有N行分别表示发生的事件。
一共有两种事件:
1:“IN A B”,表示有一个拥有优先级B的病人要求医生A诊治。(0<A<=3,0<B<=10)
2:“OUT A”,表示医生A进行了一次诊治,诊治完毕后,病人出院。(0<A<=3)
Output
对于每个"OUT A"事件,请在一行里面输出被诊治人的编号ID。如果该事件时无病人需要诊治,则输出"EMPTY"。
诊治人的编号ID的定义为:在一组测试中,"IN A B"事件发生第K次时,进来的病人ID即为K。从1开始编号。
Sample Input
7
IN 1 1
IN 1 2
OUT 1
OUT 2
IN 2 1
OUT 2
OUT 1
2
IN 1 1
OUT 1
Sample Output
2
EMPTY
3
1
1
题意:
中文题
题解:
刚好今天看了一下stl的容器, 拿来练个手,这道题目用优先队列去做就好了,具体看代码。
附上AC代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <map>
using namespace std;
int n;
struct cmp//重定义排序方式
{
        template<typename T, typename U>
        bool operator()(T const& left, U const &right) {
            if (left.first < right.first) return true;
            else if(left.first==right.first&&left.second>right.second) return true;
            return false;
        }
};
int main()
{
    char op[4];
    int dran,pran;
    while(scanf("%d",&n)!=EOF)
    {
        priority_queue<pair<int,int>,vector<pair<int,int> >,cmp> doc1;
        priority_queue<pair<int,int>,vector<pair<int,int> >,cmp> doc2;
        priority_queue<pair<int,int>,vector<pair<int,int> >,cmp> doc3;
        int id=1;
        while(n--)
        {
            scanf("%s",op);
            if(op[0]=='I')//插入新病人
            {
                scanf("%d%d",&dran,&pran);
                pair<int,int> tmp(pran,id++);
                if(dran==1)
                    doc1.push(tmp);
                else if(dran==2)
                    doc2.push(tmp);
                else if(dran==3)
                    doc3.push(tmp);
            }
            else if(op[0]=='O')//诊断好一个病人
            {
                scanf("%d",&dran);
                if(dran==1)
                {
                    if(doc1.empty())
                        printf("EMPTY\n");
                    else
                    {
                        printf("%d\n",doc1.top().second);
                        doc1.pop();
                    }
                }
                else if(dran==2)
                {
                    if(doc2.empty())
                    printf("EMPTY\n");
                    else
                    {
                        printf("%d\n",doc2.top().second);
                        doc2.pop();
                    }
                }
                else if(dran==3)
                {
                    if(doc3.empty())
                    printf("EMPTY\n");
                    else
                    {
                        printf("%d\n",doc3.top().second);
                        doc3.pop();
                    }
                }
            }
        }
    }
    return 0;
}

欢迎评论!

猜你喜欢

转载自blog.csdn.net/wjl_zyl_1314/article/details/84310819