poj3268Lake Counting(8连通分量)

Lake Counting

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 46981   Accepted: 23117

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

USACO 2004 November

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int R,C;
int ans;
#define maxn 205
char gird[maxn][maxn];
void dfs(int r,int c)
{
    if(r<0||r>=R||c<0||c>=C||gird[r][c]!='W')
    return ;
    gird[r][c]='.';
    dfs(r,c+1);
    dfs(r,c-1);
    dfs(r+1,c);
    dfs(r-1,c);
    dfs(r+1,c+1);
    dfs(r+1,c-1);
    dfs(r-1,c-1);
    dfs(r+1,c-1);
    dfs(r-1,c+1);
}
int main()
{
    while(~scanf("%d%d",&R,&C))
    {ans=0;
        for(int i=0;i<R;i++)
    for(int j=0;j<C;j++)
        scanf(" %c",&gird[i][j]);

        for(int i=0;i<R;i++)
            for(int j=0;j<C;j++)
            if(gird[i][j]=='W')
            {ans++;
                dfs(i,j);
            }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84558359