POJ——3070 Fibonacci (矩阵快速幂求fibonacci)

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fnare all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

题意:求第几项的菲波那切数。

题解:因为数据大所以需要矩阵快速幂. 递推矩阵请看代码:

import java.util.*;
public class Main {
	static Scanner cin = new Scanner(System.in);
	static class hh{
		long [][] ma = new long [2][2];
		public hh() {
			for (int i = 0; i < 2;i++) {
				for (int j = 0; j < 2;j++) {
					ma[i][j]=0;
				}
			}
		}
	}
	static hh mul(hh a, hh b,long x) {
		hh c = new hh();
		for (int i = 0; i < 2;i++) {
			for (int j = 0; j < 2;j++) {
				for (int k = 0;k < 2;k++) {
					c.ma[i][j]=(c.ma[i][j]+a.ma[i][k]*b.ma[k][j]%x)%x;
				}
			}
		}
		return c;
	}
	static hh quick(hh a,long n,long c) {//模仿数的矩阵快速幂
		hh tmp = new hh();
		for (int i = 0; i < 2;i++) tmp.ma[i][i]=1;
		while(n!=0) {
			if(n%2==1) tmp=mul(tmp,a,c);
			n/=2;
			a=mul(a,a,c);
		}
		return tmp;
	}
	public static void main(String[] args){
		long t;
		while(cin.hasNext()) {
			t=cin.nextLong();
			if(t==-1) break;
			hh a = new hh();
			hh b = new hh();
			a.ma[0][0]=1;//递推矩阵构建
			a.ma[0][1]=1;
			a.ma[1][0]=1;
			a.ma[1][1]=0;
			b=quick(a,t,10000);
			System.out.println(b.ma[1][0]%10000);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/lgz0921/article/details/83684628