hdu 6077 Time To Get Up【大模拟】

题目链接

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1226    Accepted Submission(s): 852


 

Problem Description

Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has 5 alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.

Input

The first line of the input contains an integer T(1≤T≤1440), denoting the number of test cases.

In each test case, there is an 7×21 ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.

Output

For each test case, print a single line containing a string t in the format of HH:MM, where t(00:00≤t≤23:59), denoting the time shown on the clock.

Sample Input

1

.XX...XX.....XX...XX.
X..X....X......X.X..X
X..X....X.X....X.X..X
......XX.....XX...XX.
X..X.X....X....X.X..X
X..X.X.........X.X..X
.XX...XX.....XX...XX.

Sample Output

02:38

Source

2017 Multi-University Training Contest - Team 4

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

 

题意:

给你一个时钟表,输出

分析:

就是一个大模拟,我将每个数分成8个边,构成一个8位的二进制数,然后映射到每一个具体的数

代码:

#include<bits/stdc++.h>
#define ll long long
#define mod 1000000007
using namespace std;
char c[30][100];
int a[1000];
int b[10]={5,5,2,5,5};
int main()
{
    int t,i,j,num;
    a[0]=-1;
    a[119]=0;
    a[96]=1;
    a[62]=2;
    a[124]=3;
    a[105]=4;
    a[93]=5;
    a[95]=6;
    a[100]=7;
    a[127]=8;
    a[125]=9;
    scanf("%d",&t);
    while(t--)
    {
        //scanf("%c",c[0][0]);
        for(i=0;i<7;i++)
            scanf("%s",c[i]);
        for(i=0,j=0;i<21;i+=b[j],j++)
        {
            num=0;
            if(c[1][i]=='X')
                num++;
            if(c[4][i]=='X')
                num+=(1<<1);
            if(c[0][i+1]=='X')
                num+=(1<<2);
            if(c[3][i+1]=='X')
                num+=(1<<3);
            if(c[6][i+1]=='X')
                num+=(1<<4);
            if(c[1][i+3]=='X')
                num+=(1<<5);
            if(c[4][i+3]=='X')
                num+=(1<<6);
            if(num==119||a[num])
                printf("%d",a[num]);
            else
                printf(":");
        }
        printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/lml11111/article/details/84074249