【java集合框架】SDUT 3360 学生信息的添加与查询

Problem Description

设计一个学生添加和查询的系统,从键盘读入学生的数据,然后再从屏幕显示出来。

Input

第一行有2个整数N和M,其中:N——学生数量,M——学生属性数量;
第二行有M个字符串,表示学生的属性名称,其中第1个属性id表示关键字;其中各字段属性的数据类型是确定的。
接下来有N行M列数据,分别表示学生各种属性的值,关键字相同的记录代表一个学生(后来读入的信息覆盖前面读入数据)

Output

输出所有学生的属性及数据。(每行的列数据之间用‘\t’进行分隔)

Sample Input

5 4
id name birthday score
0001 Mike 1990-05-20 98.5
0002 John 1992-05-20 67
0003 Hill 1994-05-02 36.5
0004 Christ 1996-05-20 86.5
0001 Jack 1998-05-20 96

Sample Output

id:0001	name:Jack	birthday:1998_5_20	score:96.0
id:0002	name:John	birthday:1992_5_20	score:67.0
id:0003	name:Hill	birthday:1994_5_2	score:36.5
id:0004	name:Christ	birthday:1996_5_20	score:86.5
import java.text.ParseException;
import java.text.SimpleDateFormat;
import java.util.*;

class Student {
	String id, name, date;
	double score;

	public Student(String id, String name, String date, double score) {
		super();
		this.id = id;
		this.name = name;
		this.date = date;
		this.score = score;
	}

	String dateConvert(String date) throws ParseException {
		SimpleDateFormat sdf1 = new SimpleDateFormat("yyyy-MM-dd");
		SimpleDateFormat sdf2 = new SimpleDateFormat("yyyy_M_d");
		Date date1 = sdf1.parse(date);
		return sdf2.format(date1);

	}

	@Override
	public String toString() {
		String str = null;
		try {
			str = "id:" + id + "\tname:" + name + "\tbirthday:" + dateConvert(date) + "\tscore:"
					+ String.format("%.1f", score);
		} catch (ParseException e) {
			// TODO Auto-generated catch block
			e.printStackTrace();
		}
		return str;
	}

}

public class Mainn {

	public static void main(String[] args) {
		Scanner s = new Scanner(System.in);
		int n = s.nextInt();
		Map<String, Student> map = new HashMap<String, Student>();

		s.nextLine();
		s.nextLine();

		for (int i = 1; i <= n; i++) {
			Student stu = new Student(s.next(), s.next(), s.next(), s.nextDouble());
			map.put(stu.id, stu);
		}
		Set<String> keySet = map.keySet();
		List<String> list = new ArrayList<String>(keySet);
		Collections.sort(list);
		for (String id : list) {
			Student student = map.get(id);
			System.out.println(student);
		}
		s.close();
	}

}

猜你喜欢

转载自blog.csdn.net/flyf000/article/details/84098359