我必须立即行动!

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/windywo/article/details/47813335

Time Limit:2000MS
Memory Limit:32768KB
64bit IO Format:%lld & %llu
Submit Status

Description
Tanvir returned home from the contest and got angry after seeing his room dusty. Who likes to see a dusty room after a brain storming programming contest? After checking a bit he found that there is no brush in him room. So, he called Atiq to get a brush. But as usual Atiq refused to come. So, Tanvir decided to go to Atiq’s house.

The city they live in is divided by some junctions. The junctions are connected by two way roads. They live in different junctions. And they can go to one junction to other by using the roads only.

Now you are given the map of the city and the distances of the roads. You have to find the minimum distance Tanvir has to travel to reach Atiq’s house.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a blank line. The next line contains two integers N (2 ≤ N ≤ 100) and M (0 ≤ M ≤ 1000), means that there are N junctions and M two way roads. Each of the next M lines will contain three integers u v w (1 ≤ u, v ≤ N, w ≤ 1000), it means that there is a road between junction u and v and the distance is w. You can assume that Tanvir lives in the 1st junction and Atiq lives in the Nth junction. There can be multiple roads between same pair of junctions.

Output
For each case print the case number and the minimum distance Tanvir has to travel to reach Atiq’s house. If it’s impossible, then print ‘Impossible’.

Sample Input
2

3 2
1 2 50
2 3 10

3 1
1 2 40
Sample Output
Case 1: 60
Case 2: Impossible

#include<cstdio>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int n,m;
int cost[120][120],dis[120],used[120];
void dijkstra(int s)
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=INF;
        used[i]=false;
    }
    dis[s]=0;
    while(true)
    {
        int v=-1;
        for(int u=1;u<=n;u++)
            if(!used[u]&&(v==-1||dis[u]<dis[v]))
                v=u;
        if(v==-1) break;
        used[v]=true;
        for(int u=1;u<=n;u++)
            dis[u]=min(dis[u],dis[v]+cost[v][u]);
    }
}
int main()
{
    int a,b,c,i,j;
    int t,k=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
                cost[i][j]=INF;
        }
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(c<cost[a][b])
                cost[a][b]=cost[b][a]=c;
        }
        dijkstra(1);
        //printf("%d\n",dis[n]);
        printf("Case %d: ",k++);
        if(dis[n]<INF)
            printf("%d\n",dis[n]);
        else
            printf("Impossible\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/windywo/article/details/47813335