数据结构-最长连续递增子序列

7-9 最长连续递增子序列 (20 分)

给定一个顺序存储的线性表,请设计一个算法查找该线性表中最长的连续递增子序列。例如,(1,9,2,5,7,3,4,6,8,0)中最长的递增子序列为(3,4,6,8)。

输入格式:

输入第1行给出正整数n(≤10​5​​);第2行给出n个整数,其间以空格分隔。

输出格式:

在一行中输出第一次出现的最长连续递增子序列,数字之间用空格分隔,序列结尾不能有多余空格。

输入样例:

15
1 9 2 5 7 3 4 6 8 0 11 15 17 17 10

输出样例:

3 4 6 8
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 100005
int a[maxn];
int main()
{
	int n;
	scanf("%d",&n);
	for(int i = 0; i < n; i ++)
		scanf("%d",&a[i]);
	int count = 0,j = 0,k;
	for(int i = 1; i < n; i ++)
	{
		if(a[i]>a[i-1])
		{
			count++;
			if(count>j)
			{
				j = count;
				k = i;
			}
		}
		else
		 	count = 0;
	}
	int start = k-j;
	int end = k;
	if(j>0)
	{
		int flag = 0;
		for(int t = start; t <= end; t ++)
		{
			if(!flag)
			{
				printf("%d",a[t]);
				flag = 1;
			}
			else 
				printf(" %d",a[t]);
		}
	}
	else
		printf("%d\n",a[0]);
}

猜你喜欢

转载自blog.csdn.net/qiulianshaonv_wjm/article/details/84259372