字典树模板题 Shortest Prefixes

B - Shortest Prefixes

Time Limit:1000MS     Memory Limit:30000KB    

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
#include <iostream>
#include <algorithm>
using namespace std;
#include <cstring>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cmath>
const int maxn = 26;
struct Trie
{
    Trie *Next[maxn];
    int sum;  // 计数,即前缀的个数 从该结点向上找,以该字符串为前缀的个数
    int flag;  // 结束标志
    int val;   //权值
    Trie()
    {
        sum = 0;
        for(int i = 0; i < maxn; i++)
            Next[i] = NULL;
    }
};
Trie *root=NULL;
void CreatTrie(string str)
{
    int len=str.size();
    Trie *p=root,*q;
    for(int i=0;i<len;i++)
    {
        int id=str[i]-'a';
        if(p->Next[id]==NULL) //如果该字母没有出现过,则新建一个结点
        {
            q=new Trie();
            q->sum=1;
            p->Next[id]=q;
            p=p->Next[id];
        }
        else   //出现过的话,只需要移到下一个结点即可
        {
            p->Next[id]->sum++;
            p=p->Next[id];
        }
    }
    return ;
}
void FindTrie(string str)
{
    int len=str.size();
    Trie *p=root;
    for(int i=0;i<len;i++)
    {
        int id=str[i]-'a';
        cout<<str[i];
        p=p->Next[id];
        if(p->sum==1)
            return ;
    }
}
int main()
{
    root =new Trie();
    char str[1010][50];
    int i=0;
    while(scanf("%s",str[i])!=EOF)
    {
        CreatTrie(str[i++]);
    }
    for(int j=0;j<i;j++)
    {
        cout<<str[j]<<" ";
        FindTrie(str[j]);
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Septembre_/article/details/84174548