程序设计基础39 入门模拟

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

一,注意点

1,关于时间超时的问题,采取的措施是在输入的时候进行一个dis[]数组的计算。然后真要计算的时候就用dis[right-1]-dis[left-1],而不是从头开始循环。

二,代码

#include<cstdio>
#include<algorithm>
using namespace std;
int arr[100010];
int dis[100010];
int main() {
	int num = 0;
	int sum = 0;
	scanf("%d", &num);
	for (int i = 1; i <= num; i++) {
		scanf("%d", &arr[i]);
		sum += arr[i];
		dis[i]=sum;
	}
	int countting = 0;
	int num_1=0,num_2=0;
	int sum_1=0;
	int temp=0;
	scanf("%d", &countting);
	for(int i=0;i<countting;i++){
		sum_1=0;
		scanf("%d %d",&num_1,&num_2);
		if(num_1>num_2){
			temp=num_1;
			num_1=num_2;
			num_2=temp;
		}
		sum_1=dis[num_2-1]-dis[num_1-1];
		printf("%d\n",min(sum_1,sum-sum_1));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/84167538