1151 LCA in a Binary Tree(30 point(s))

1151 LCA in a Binary Tree(30 point(s))

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

//AC code
/*
  1:根据中序,先序建树 
  2: 用 findnode( )查看待查询节点是否存在
  3:若待查询节点是存在,用 LCA( )查找最近公共祖先 
 其中LCA有三种: 
    u,v都在左子树或右子树,或者u,v分别在左子树和右子树,
 因此可采取如下步骤:
    (1)::判断当前遍历的节点是否为空,为空返回null,
    (2)::节点数据域是否等于u,是否等于p,是的话返回当前节点。
    (3)::之后判断left 和right是否为空, 若都不为空 ,则当前root为祖先指针,
        若其中一个为空,则返回另一边,为答案。
  4:格式输出 
*/ 
#include<cstdio>
#include<queue>
#include<map>
#include<algorithm>
using namespace std;
const int maxn=10010;
struct node{
    int data;
    node *lchild,*rchild;
};

int pre[maxn],in[maxn];
int n,k,u,v;

node *creat(int prel,int prer,int inl,int inr){
    if(prel>prer){
        return NULL;
    }
    node *root=new node;
    root->data=pre[prel]; 
    int k;
    for( k=inl;k<=inr;k++){
        if(in[k]==pre[prel])
        break;
    }  
    int leftnum=k-inl; 
    root->lchild =creat(prel+1,prel+leftnum,inl,k-1); //下标要写对哦
    root->rchild =creat(prel+leftnum+1,prer,k+1,inr);
    return root;
}

bool findnode(int u){ //查找节点 
    for(int i=0;i<n;i++){
        if(u==pre[i])
         return true;
    }
    return false;
}

node *LCA(node *root, int u, int v) { //查找两节点最近祖先 
        if (root == NULL) return NULL;
        if (root->data== u || root->data== v) return root;
        node *left =LCA(root->lchild,u,v);
        node *right = LCA(root->rchild,u,v);
        if (left && right ) return root; //u,v分别位于左右子树的情况
        return left == NULL ? right : left;
}

int main(){
    scanf("%d %d",&k,&n);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&pre[i]);
    node *root=creat(0,n-1,0,n-1); // 尴尬,刚开始中序,先序顺序输反了,调了半天bug 
    for(int i=0;i<k;i++){
        scanf("%d %d",&u,&v);
        if(findnode(u)==false && findnode(v)==false)
           printf("ERROR: %d and %d are not found.\n", u, v);
        else if (findnode(u)==false || findnode(v)==false)
            printf("ERROR: %d is not found.\n", findnode(u)==false ? u : v);
        else {
            node *temp=LCA(root,u,v);
            if(temp->data==u || temp->data==v){
               printf("%d is an ancestor of %d.\n",temp->data==u? u:v,temp->data==u? v:u);
            }else{
                printf("LCA of %d and %d is %d.\n",u,v,temp->data);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41317652/article/details/82557975
今日推荐