hdu sort 排序

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 17   Accepted Submission(s) : 17

Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input

 

3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2

Sample Output

 

6 5 3 1 2 1

英文题一定要看,一定要看。。。。

简单的排序。。。。

第一次将获得最多的评分排序,再对编号排序。。。。 

#include<bits/stdc++.h>
using namespace std;
int c[1010];
double num;
struct px
{
    int p;
    double s;
}a[1010];
int cmp1(px a,px b)
{
    return a.s>b.s;
}
int cmp2(px x,px y)
{
    return x.p>y.p;
}
int main()
{
    int n,m,k;
    int i,j;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        for(i=0; i<m; i++)
        {
            a[i].p=i+1;
            a[i].s=0;
        }
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                scanf("%lf",&num);
                a[j].s+=num;
            }
        }
        sort(a,a+m,cmp1);
        sort(a,a+k,cmp2);
        for(i=0; i<k-1; i++)
        {
            printf("%d ",a[i].p);
        }
        printf("%d\n",a[k-1].p);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/smilelingling/article/details/82623203