Dungeon Master (DFS)

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!


#include "iostream"
#include "queue"
#include "cstring"
using namespace std;
queue<int> que;
char map[32][32][32];
int book[32][32][32];
struct point
{
	int x,y,z;
	int step;
};
int l,r,c;
point start,end;
int bfs()
{
	int next[6][3]={{0,0,1},{0,1,0},{1,0,0},{0,0,-1},{-1,0,0},{0,-1,0}};
//上面的next可以稍微的记忆下这种用法!!!

	queue<point> que;
	que.push(start);
	memset(book,0,sizeof(book));
//因为S 和 E是必定不可能在一个位置上的,所以这里并不需要判断
	book[start.x][start.y][start.z]=1;
	while(!que.empty())
	{
		point cur=que.front();
		que.pop();//删除直接在这里用就好了,放在循环结束很容易忘记
		for(int i=0;i<=5;i++)
		{
			point now=cur;
			now.x=cur.x+next[i][0];
			now.y=cur.y+next[i][1];
			now.z=cur.z+next[i][2];
			now.step=cur.step+1;
			if(now.x>=0&&now.y>=0&&now.z>=0&&now.x<l&&now.y<r&&now.z<c&&book[now.x][now.y][now.z]==0&&map[now.x][now.y][now.z]!='#')
//注意判断条件,一定判断x,y,z的合理性在前!!!否则数组越界
			{
				que.push(now);
				book[now.x][now.y][now.z]=1;
				if(now.x==end.x&&now.y==end.y&&now.z==end.z)
				{
					return now.step;
				}
//在这里就可以进行对值进行判断了,算法复杂度会变小,大概小6倍,判断放在上面也可以
			}
			
		}
	}
	return -1;
}
int main()
{
	while(~scanf("%d%d%d",&l,&r,&c))
	{
		if(l==0&&r==0&&c==0)
		break;
		getchar();
		for(int i=0;i<l;i++)
		{
			for(int j=0;j<r;j++)
			{
				for(int k=0;k<c;k++)
				{
					scanf("%c",&map[i][j][k]);
					if(map[i][j][k]=='S')
					{
						start.x=i;
						start.y=j;
						start.z=k;
						start.step=0;
					}
					if(map[i][j][k]=='E')
					{
						end.x=i;
						end.y=j;
						end.z=k;
					}
				}
				getchar();
			}
			if(i!=(l-1))
			getchar();
		}
		if(bfs()==-1)
		{
			cout<<"Trapped!"<<endl;
		}
		else
		{
			cout<<"Escaped in "<<bfs()<<" minute(s)."<<endl;
		}
	}	
	return 0;
 } 

 直接用模板就好!!!

猜你喜欢

转载自blog.csdn.net/weixin_41466575/article/details/82890071