【二分答案+01分数规划搜索】POJ - 2976 D - Dropping tests

D - Dropping tests  POJ - 2976 

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

扫描二维码关注公众号,回复: 3955995 查看本文章

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

 题目大意就 给定n个二元组(a,b),扔掉k个二元组,使得剩下的a元素之和与b元素之和的比率最大

     题目求的是 max(∑a[i] * x[i] / (b[i] * x[i]))   其中a,b都是一一对应的。 x[i]取0,1  并且 ∑x[i] = n - k;

    转:那么可以转化一下。  令r = ∑a[i] * x[i] / (b[i] * x[i])  则必然∑a[i] * x[i] - ∑b[i] * x[i] * r= 0;(条件1)

并且任意的 ∑a[i] * x[i] - ∑b[i] * x[i] * max(r) <= 0  (条件2,只有当∑a[i] * x[i] / (b[i] * x[i]) = max(r) 条件2中等号才成立)

所以

二分
const double eps=1e-7
while(r-l>=eps)
{
	double mid=(l+r)/2.0;
	if(ok(mid))
	{
		l=mid;
		ans=mid;
	}
	else r=mid;
}

特别注意!!!

输出不要用lf poj可能会WA printf("%f",ans); 

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
double a[1050],b[1050],c[1050];
const double eps=1e-7;
int n,m;

bool cmp(const double &x,const double &y)
{
	return x>y;
}

bool ok(double x)
{
	for(int i=1;i<=n;i++)
		c[i]=a[i]-b[i]*x;
	sort(c+1,c+n+1,cmp);
	double sum=0;
	for(int i=1;i<=n-m;i++) sum+=c[i];
	if(sum>0) return 1;
	else return 0;
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&&m==0) break;
		for(int i=1;i<=n;i++)
			scanf("%lf",&a[i]);
		for(int i=1;i<=n;i++)
			scanf("%lf",&b[i]);
		double l=0.0,r=1.0;
		double ans=0;
		while(r-l>=eps)
		{
			double mid=(l+r)/2.0;
			if(ok(mid))
			{
				l=mid;
				ans=mid;
			}
			else r=mid;
		}
		printf("%.0f\n",ans*100);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/83023431
今日推荐