F - Rain on your Parade (HK)

F - Rain on your Parade

You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
Can you help your guests so that as many as possible find an umbrella before it starts to pour?

Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however.

Input

The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= s i <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
The absolute value of all coordinates is less than 10000.

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.

Sample Input

2
1
2
1 0 3
3 0 3
2
4 0
6 0
1
2
1 1 2
3 3 2
2
2 2
4 4

Sample Output

Scenario #1:
2

Scenario #2:
2

题意:

        先给出距离下雨的时间,再给出n个人和m把雨伞的坐标位置,以及每个人的奔跑速度。每把雨伞只能供一人使用。求在下雨前最多有多少人可以拿到雨伞。

思路:

       二分匹配 + HK算法(看了很多博客,并没有看懂)

只有模板:http://www.cnblogs.com/kuangbin/archive/2011/08/12/2135898.html

注意: 

       1) 在判断客人是否能达到有伞的地方的函数——Pan(),要用double型。

       2)本代码从 1 开始。。。

代码:

  

#include<map>
#include<queue>
#include<math.h>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define MM 3005
const int INF=1e9;
int line[MM][MM],book[MM];
int mx[MM],my[MM],dx[MM],dy[MM],nx,ny,dis;
int t,gu,un;
struct zaq
{
    int x,y,s;
} g[MM],u[MM];
bool Pan(zaq A,zaq B)
{
    double ans;     //用double型
    ans=sqrt((B.x-A.x)*(B.x-A.x)+(B.y-A.y)*(B.y-A.y));
    if(ans<=t*A.s)
        return true;
    else
        return false;
}
bool Search()
{
    queue<int>qu;
    dis=INF;
    mem(dx,0);
    mem(dy,0);
    for(int i=1; i<=nx; i++)
    {
        if(!mx[i])
        {
            qu.push(i);
            dx[i]=0;
        }
    }
    while(!qu.empty())
    {
        int kk=qu.front();
        qu.pop();
        if(dx[kk]>dis)
            break;
        for(int v=1; v<=ny; v++)
        {
            if(line[kk][v] && !dy[v])
            {
                dy[v]=dx[kk]+1;
                if(!my[v])
                    dis=dy[v];
                else
                {
                    dx[my[v]]=dy[v]+1;
                    qu.push(my[v]);
                }
            }
        }
    }
    return dis != INF;
}
bool Find(int x)
{
    for(int v=1; v<=ny; v++)
    {
        if(!book[v] && line[x][v] && dy[v]==dx[x]+1)
        {
            book[v]=1;
            if(my[v] && dy[v]==dis)
                continue;
            if(!my[v] || Find(my[v]))
            {
                my[v]=x;
                mx[x]=v;
                return true;
            }
        }
    }
    return false;
}
void match()
{
    int ans=0;
    mem(mx,0);
    mem(my,0);
    while(Search())
    {
        mem(book,0);
        for(int i=1; i<=nx; i++)
        {
            if(!mx[i] && Find(i))
                ans++;
        }
    }
    printf("%d\n",ans);
}
int main()
{
    int ca,cas=1;
    scanf("%d",&ca);
    while(ca--)
    {
        mem(line,0);
        scanf("%d",&t);
        scanf("%d",&gu);
        for(int i=1; i<=gu; i++)
            scanf("%d%d%d",&g[i].x,&g[i].y,&g[i].s);
        scanf("%d",&un);
        for(int i=1; i<=un; i++)
            scanf("%d%d",&u[i].x,&u[i].y);
        for(int i=1; i<=gu; i++)
            for(int j=1; j<=un; j++)
                if(Pan(g[i],u[j]))
                    line[i][j]=1;
        nx=gu;
        ny=un;
        printf("Scenario #%d:\n",cas++);
        match();
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/team39/article/details/81257535
HK