Gone Fishing(优先队列实现)

版权声明:转载请注明出处:https://blog.csdn.net/qq1013459920 https://blog.csdn.net/qq1013459920/article/details/83014006

                                              Gone Fishing

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

题意:John有h个小时的钓鱼时间,一共有n个湖泊,它们在一条直线上。从第1个湖开始,可以在任意一个湖停下,每到达一个湖,这个湖开始有f[i]条鱼,钓一次鱼需要5分钟,5分钟后(即钓完鱼后)这个湖的鱼的数量为上次数量减去d[i],并且从第i个湖到第i+1个湖需要ti*5的时间。如果某个时间段期望钓到的鱼数小于或者等于di,那么下一个时间段湖中将不再有鱼剩下。为了简化计划,John假设没有其他钓鱼人影响到他的钓鱼数目。目标是让他能钓到的鱼最多。在每个湖他所花的时间必须是5分钟的倍数。

方法:重载<,利用优先队列来给最优钓鱼湖排序,具体思路还请看代码...

关于优先队列中每次队首元素可能不是一个湖,本蒟蒻思路良久,得出以下结论:

有人认为:

因为优先队列每次的队首元素可能不是一个湖。
觉得应该把中间步行回去的时间算进来。
实际上,是不用的,假设一种情况下每次的队首元素分别是0湖,1湖,0湖。
在实际钓鱼中就是在0湖钓鱼2次,在1湖钓鱼1次。
相当于优先队列使这个人提前知道应该在哪个湖钓几次,而不是每次来回去找可以钓鱼最多的那个湖

Code :

#include<iostream>
#include<sstream>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<ctype.h>
#include<map>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<list>
#define mod 998244353
#define Max 0x3f3f3f3f
#define Min 0xc0c0c0c0
#define mst(a) memset(a,0,sizeof(a))
#define f(i,a,b) for(int i=a;i<b;i++)
using namespace std;
typedef long long ll;
int n, h, maxs;
int ans[30], times[30];         //ans数组记录最优方案下每个湖花费的时间,times数组则用于记录各种方案下的时间花费

struct Node{
    int sno;                //第几个湖
    int fish_num;           //鱼的数目
    int fish_reduce;        //鱼的减少数(每5分钟)
    int sno_time;           //记录从0湖到i湖走路花费的时间
    friend bool operator < (const Node &a, const Node &b){      //重载小于<,用于优先队列
        if(a.fish_num == b.fish_num){
            return a.sno > b.sno;
        }
        return a.fish_num < b.fish_num;
    }
}arr[30];

priority_queue<Node> Q;

void greed(){                       //贪心算法
    maxs = -1;
    for(int i = 0; i < n; i++){         //遍历所有情况,即总路线为从0湖到i湖的所有情况(包括一直在0湖)
        while(!Q.empty()){          //队列清空
            Q.pop();
        }
        int left_time = h - arr[i].sno_time;    //除去步行后的时间,即为用于钓鱼的时间
        int sum = 0;
        for(int j = 0; j <= i; j++){        
            Q.push(arr[j]);         //入优先队列,在重载<的情况下(便于获取最优方案)
        }
        mst(times);                 //times数组每次清空
/*
(有人可能会有疑问:因为优先队列每次的队首元素可能不是一个湖。
觉得应该把中间步行回去的时间算进来。
实际上,是不用的,假设一种情况下每次的队首元素分别是0湖,1湖,0湖。
在实际钓鱼中就是在0湖钓鱼2次,在1湖钓1次。
相当于优先队列使这个人提前知道哪个湖应该钓几次,而不是每次来回去找可以钓鱼最多的那个湖)
*/
        while(left_time > 0){
            Node temp = Q.top();     //temp(结构体变量)为队首元素,保证原数据不变
            Q.pop();                    //出队(队列基本操作)
            if(temp.fish_num <= 0){     //一旦队首元素都没有鱼可钓,则说明所有湖均无鱼
                break;
            }
            //下面就是一个模拟钓鱼的过程,不过把中间需要步行的过程去掉了
            sum += temp.fish_num;       //统计钓鱼数
            temp.fish_num -= temp.fish_reduce;  //鱼数目减少
            times[temp.sno] += 5;               //在该湖的花费时间增加
            Q.push(temp);                   //temp继续入队,按重载后的优先级排序
            left_time -= 5;                 //钓鱼时间减少
        }
        if(left_time > 0){                  //郁闷了好久,原来样例1中多出的时间是:     钓鱼用不完的时间,放在第一个湖那里
            times[0] += left_time;
        }
        if(sum > maxs){             //出现0湖到i湖的方案可以获取更多的鱼数目(即更优方案),则使用该方案
            maxs = sum;             //最大鱼数目更换
            for(int t = 0; t < n; t++){ 
                ans[t] = times[t];      //在每个湖的花费时间更换
            }
        }
    }
}
int main(){
    ios::sync_with_stdio(false);
    int cnt = 0;
    while(cin>>n){
        if(n == 0){
            break;
        }
        cin>>h;
        h *= 60;
        for(int i = 0; i < n; i++){         //输入
            cin>>arr[i].fish_num;
            arr[i].sno = i;
        }
        for(int i = 0; i < n; i++){
            cin>>arr[i].fish_reduce;
        }
        arr[0].sno_time = 0;                //初始在0湖
        int temp;
        for(int i = 1; i < n; i++){
            cin>>temp;
            arr[i].sno_time = arr[i-1].sno_time + (temp)*5;     //   0湖到i湖的时间  =(0湖到i-1湖的时间)+t*5
        }
        greed();        //贪心算法
        if(cnt > 0){        //输出格式,除第一行外其他都要空一行
            cout<<endl;
        }
        cout<<ans[0];
        for(int i = 1; i < n; i++){
            cout<<", "<<ans[i];
        }
        cout<<endl;
        cout<<"Number of fish expected: "<<maxs<<endl;
        cnt++;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq1013459920/article/details/83014006