HDU 2289 Cup

圆台的体积公式:

其中r是上底面半径,R是下底面半径

Problem Description

The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.

Input

The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.
 

Output

For each test case, output the height of hot water on a single line. Please round it to six fractional digits.

Sample Input

1 100 100 100 3141562

Sample Output

99.999024

题意:给出圆台的底面半径,顶部半径,高还有水的体积,求水的高度

思路:我们可以直到水的高度必然在0到最大高度之间,在这个区间内进行二分即可,注意这里水的上底面面积是变化的

#include<stdio.h>
#include<math.h>
const double PI = acos(-1.0); //重点 
const double eps = 1e-8;


double getV(double r,double R,double h,double H)
{
	double u = h/H*(R-r) + r;
    return PI/3*(r*r+r*u+u*u)*h;
}

int main()
{
	int t;
	double r,R,h,v;
	double l=0.0,r1=0.0,ans=0.0,mid;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf%lf%lf",&r,&R,&h,&v);
		l = 0.0,r1 = h;
		while(r1-l>eps)
		{
			mid=(l+r1)/2;
			ans = getV(r,R,mid,h);
			if(fabs(ans-v) <= eps) break;
		    else if(ans > v) r1 = mid-1e-7;
			else  l = mid+1e-7;
		}
		printf("%.6lf\n",mid);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40511966/article/details/82949200
CUP