PAT甲级 1083 List Grades (25 分)排序水题

1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

题目大意: 给出n个考生信息,从高分到低分输出考生信息,要求输出的考生满足在给定分数区间。 没有符合的输出NONE。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct node{
	string name,id;
	int grade;
};

int cmp(node a,node b){
	return a.grade > b.grade;
}

int main(){
	int n;
	cin>>n;
	vector<node> vec(n);
	for(int i=0;i<n;i++)
		cin>>vec[i].name>>vec[i].id>>vec[i].grade;
	
	sort(vec.begin(),vec.end(),cmp);
	int a,b,flag = 0;
	cin>>a>>b;
	for(int i=0;i<n;i++)
		if(vec[i].grade >= a && vec[i].grade <= b){
			cout<<vec[i].name<<" "<<vec[i].id<<endl;
			flag = 1;
		}		
	
	if(flag == 0)
		cout<<"NONE";
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/83240523