World Exhibition HDU - 3592

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_40758751/article/details/82252422

World Exhibition

HDU - 3592

Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.

Input

First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y.

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.

Output

For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.

Sample Input

1
4 2 1
1 3 8
2 4 15
2 3 4

Sample Output

19

AC代码

//#include<bits/stdc++.h>
#define _CRT_SBCURE_NO_DEPRECATE
#include <set>
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
//#define UP(i,x,y) for(int i=x;i<=y;i++)
//#define DOWN(i,x,y) for(int i=x;i>=y;i--)
#define sdddd(x,y,z,k) scanf("%d%d%d%d", &x, &y, &z, &k)
#define sddd(x,y,z) scanf("%d%d%d", &x, &y, &z)
#define sdd(x,y) scanf("%d%d", &x, &y)
#define sd(x) scanf("%d", &x)
#define mp make_pair
#define pb push_back
#define lson k<<1
#define rson k<<1|1
#define mid (l+r)/2
#define ms(x, y) memset(x, y, sizeof x)
using namespace std;
typedef long long ll;
//typedef unsigned long long ull;
#define MOD 142857
const int maxn = 10100;
const int INF = 0x3f3f3f3f;
const ll LINF = 0x3f3f3f3f3f3f3f3f;
int n, m, s, t;
int len;
struct road
{
	int u, v, len;
	int next;
	void getvalue(int uu, int vv, int ll, int nn)
	{
	    u = uu; v = vv; len = ll; next = nn;
	}
	road(){}
};
struct node
{
    int v;
    int len;
    int cost;
    node(int v, int l, int c):v(v),len(l),cost(c){}
    friend bool operator <(node a, node b)
    {
        return a.cost>b.cost;
    }
};
road G[maxn*5];
int h[maxn];
int d[maxn];
int c[maxn];
bool vis[maxn];
int spfa()
{
    fill(d, d+n+1, INF);
    d[1] = 0;
    ms(c,0);
    ms(vis,0);
    queue<int> q;
    q.push(1);
    while(q.size())
    {
        int x = q.front(); q.pop();
        vis[x] = 0;
        c[x]++;
        if(c[x] > n) return 0;
        for(int i = h[x]; i!=-1; i=G[i].next)
        {
            road e = G[i];
            if(d[e.v] > d[e.u] + e.len)
            {
                d[e.v] = d[e.u] + e.len;
                if(!vis[e.v])
                {
                    q.push(e.v);
                    vis[e.v] = 1;
                }
            }
        }
    }
    return 1;
}
int main()
{
	//freopen("out.txt", "w", stdout);
	sd(t);
    while(t--)
    {
        sddd(n, m, s);
        int ta, tb, tc;
        len = 0;
        fill(h, h+n+1, -1);
        for(int i = 0; i < m; i++)
        {
            sddd(ta, tb, tc);
            G[len].getvalue(ta,tb,tc,h[ta]);
            h[ta] = len++;
        }
        for(int i = 0; i < s; i++)
        {
            sddd(ta, tb, tc);
            G[len].getvalue(tb,ta,-tc,h[tb]);
            h[tb] = len++;
        }
//        for(int i = n; i > 1; i--)
//        {
//            G[len].getvalue(i,i-1,0,h[i]);
//            h[i] = len++;
//        }
        int flag = spfa();
        if(!flag)
        {
            puts("-1");
        }
        else
        {
            if(d[n] == INF)
            {
                puts("-2");
            }
            else
            {
                printf("%d\n", d[n]);
            }
        }
    }

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40758751/article/details/82252422
今日推荐