I Think I Need a Houseboat(poj 1005)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_25203255/article/details/78907673

1 问题描述

Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)


这里写图片描述

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

大致意思

给你个坐标(x,y),坐标点肯定位于x轴上方,有一个半圆,从原点每次增加50单位面积,问增加多少次才能刚好覆盖这个点

题目地址poj 1005

2 算法思路

本题主要判断点是否在半圆中,可以先计算给定坐标点到原点的距离r,然后使用这个距离r画出的半圆面积需要多少个50即可。
参考公式:

  1. 平面两点距离公式
    D=(x21x22)+(y21y22)
    又因是计算到原点(0, 0)的距离,公式简化为 Dto(0,0)=x2+y2
  2. 半圆面积公式
    S=πr22

3 算法实现

#include <iostream>
#include <cmath>
#include <cstdio>
#include <vector>

using namespace std;

#define PI 3.1415926

int main()
{
    int N, i;
    // 保存坐标到原点的距离
    vector<double> distances;
    cin >> N;
    for(i = 0; i < N; ++ i) {
        double x, y;
        cin >> x >> y;
        // 两点距离公式
        distances.push_back(sqrt(x*x + y*y));
    }
    for(i = 0; i < N; ++ i) {
        double r = distances[i];
        // 半圆需要除2
        printf("Property %d: This property will begin eroding in year %d.\n", i+1, (int)(PI*r*r/100) + 1);
    }
    cout << "END OF OUTPUT.";
    return 0;
}

4 数据测试


这里写图片描述

猜你喜欢

转载自blog.csdn.net/qq_25203255/article/details/78907673
今日推荐