C语言实验——删除指定字符

C语言实验——删除指定字符

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

从键盘输入一个字符串给str和一个字符给c,删除str中的所有字符c并输出删除后的字符串str。

Input

第一行是一个字符串,不超过100个字符;
第二行是一个字符。

Output

删除指定字符后的字符串。

Sample Input

sdf$$$sdf$$
$

Sample Output

sdfsdf

Hint

Source


using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Text.RegularExpressions;
using System.Threading.Tasks;

namespace test1
{
    class Program
    {
        static void Main(string[] args)
        {
            string s=Console.ReadLine();
            string c = Console.ReadLine();
            
            for(int i=0;i<s.Length;i++)
            {
                if (s[i] != char.Parse(c))
                {
                    Console.Write(s[i]);
                }
            }
            Console.WriteLine();
        }
    }
}

猜你喜欢

转载自blog.csdn.net/feissss/article/details/82948735