B - Carries SCU - 4437

版权声明:转载请注明出处: https://blog.csdn.net/qq_38701476/article/details/82875109

Carries
frog has n integers a1,a2,…,an, and she wants to add them pairwise.

Unfortunately, frog is somehow afraid of carries (进位). She defines hardness h(x,y) for adding x and y the number of carries involved in the calculation. For example, h(1,9)=1,h(1,99)=2.

Find the total hardness adding n integers pairwise. In another word, find
∑1≤i<j≤nh(ai,aj)
.

Input
The input consists of multiple tests. For each test:

The first line contains 1 integer n (2≤n≤105). The second line contains n integers a1,a2,…,an. (0≤ai≤109).

Output
For each test, write 1 integer which denotes the total hardness.

Sample Input
2
5 5
10
0 1 2 3 4 5 6 7 8 9
Sample Output
1
20

  • 题意:给你n个数,求这n个数中任意两个数间想加进位了多少次
  • 题解:直接把这n个数除以 1 0 k 10^k ,然后把这n个数排下序,最后在这n个数中找满足相加> 1 0 k 10^k 的对数.k从1到9遍历一遍
#include<bits/stdc++.h>
#define mk make_pair
#define endl '\n'
#define pb pusk_back
#define _ ios::sync_with_stdio(false)
using namespace std;
typedef long long ll;
const double EPS = 1e-10;
const double PI = acos(-1);
bool SUBMIT = 1;
const int inf = 1e5+10;
int a[inf],b[inf];
int main()
{
    if(!SUBMIT)freopen("i.txt","r",stdin);else _;    
    int n;
    while(cin>>n){
        for(int i=0;i<n;i++)cin>>a[i];
        ll ans=0,m=1;
        for(int i=0;i<9;i++){
            m*=10;
            for(int j=0;j<n;j++)b[j]=a[j]%m;
            sort(b,b+n);
            int t=0;
            for(int j=n-1;j>=0;j--){
                for(;t<j;t++){
                    if(b[t]+b[j]>=m){
                        //cout<<"----"<<endl;
                        ans+=j-t;break;
                    }
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38701476/article/details/82875109