poj 3614 Sunscreen(贪心加优先队列)

Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi 
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1

Sample Output

2

Source

扫描二维码关注公众号,回复: 3489035 查看本文章

优先队列维护,奶牛最小承受值由小到大排序,防晒霜spf值有小到大排序,然后贪心,优先队列维护,最小承受值小的先入队,最大承受能力小的先出队

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct cow
{int left,right;

}c[2510];
struct sun
{
    int score,num;
}s[2510];
bool cmp1(cow a,cow b)
{
    return a.left<b.left;
}
bool cmp2(sun a,sun b)
{
    return a.score<b.score;
}
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    scanf("%d%d",&c[i].left,&c[i].right);
    for(int i=1;i<=m;i++)
    scanf("%d%d",&s[i].score,&s[i].num);
    sort(c+1,c+1+n,cmp1);
    sort(s+1,s+m+1,cmp2);
    int j=1;
    int ans=0;
    priority_queue<int,vector<int>,greater<int> >q;
    for(int i=1;i<=m;i++)
    {
        while(j<=n&&c[j].left<=s[i].score)
        {
            q.push(c[j].right);
            j++;
        }
        while(!q.empty()&&s[i].num!=0)
        {
            int w=q.top();
            q.pop();
            if(w>=s[i].score)
            {
                ans++;
                s[i].num--;
            }
        }
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/82928807