Fire Game(BFS,双点)

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input
4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#
Sample Output
 
 

Case 1: 1 Case 2: -1 Case 3: 0 Case 4: 2


又长见识了,Bfs还可以这样玩,多刷题还是很重要的啊。

用一个结构体数组储存每个‘#’的位置,然后依次枚举两个点用bfs求出需要的最小时间。。
刚开始还想着判断有几组草丛,后来发现无需判断,只要最后存在bfs没有遍历到的点,就说明不能成立!

代码部分:#include <cstdio>
#include <algorithm>
#include <queue>
#include <string.h>
using namespace std;
int n,m;
struct Node
{
    int x,y,s;
}node[101];
int next[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char str[101][101];
int book[101][101];
int bfs(Node a,Node b)
{
    queue<Node>Q;
    int i,row,col;
    Q.push(a);
    Q.push(b);
    Node q;
    while(Q.size())
    {
        q=Q.front();
        Q.pop();
        for(i=0;i<4;i++)
        {
            Node p;
            p.x=q.x+next[i][0];
            p.y=q.y+next[i][1];
            if(p.x<0||p.y<0||p.x>n-1||p.y>m-1)
            {
                continue;
            }
            if(book[p.x][p.y]==0&&str[p.x][p.y]=='#')
            {
                p.s=q.s+1;
                Q.push(p);
                book[p.x][p.y]=1;
            }
        }
    }
    return q.s;
}
bool judge()
{
    int i,j;
    for(i=0;i<n;i++)
    {
        for(j=0;j<m;j++)
        {
            if(str[i][j]=='#'&&book[i][j]==0)
            {
                return 0;
            }
        }
    }
    return 1;
}
int main()
{
    int t,i,j,ans,k,res;
    scanf("%d",&t);
    int time=1;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        k=0;
        for(i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            for(j=0;j<m;j++)
            {
                if(str[i][j]=='#')
                {
                    node[k].x=i;
                    node[k].y=j;
                    node[k].s=0;
                    k++;
                }
            }
        }
        res=99999999;
        for(i=0;i<k;i++)
        {
            for(j=i;j<k;j++)
            {
                book[node[i].x][node[i].y]=1;
                book[node[j].x][node[j].y]=1;
                ans=bfs(node[i],node[j]);
                if(judge())
                {
                    res=min(res,ans);
                }
                memset(book,0,sizeof(book));
            }
        }
        if(res==99999999)
            printf("Case %d: -1\n",time++);
        else
            printf("Case %d: %d\n",time++,res);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a201707090/article/details/80394510