ACM-ICPC 2018 南京赛区网络预赛 签到水题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/DADDY_HONG/article/details/82291883

A An Olympian Math Problem

  •  1000ms
  •  65536K

Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k!=1×2×⋯×(k−1)×k

We denote S:

S=1×1!+2×2!+⋯+(n−1)×(n−1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer n.

It is guaranteed that 2≤n≤10^18.

Output

For each test case, print an integer S modulo n.

Hint

The first test is: S=1×1!=1, and 1 modulo 2 is 1.

The second test is: S=1×1!+2×2!=5 , and 5 modulo 3 is 2.

样例输入

2
2
3

样例输出

1
2

题目来源

ACM-ICPC 2018 南京赛区网络预赛

S = 1×1!+2×2!+⋯+(n−1)×(n−1)!

(n-1)*(n-1)!+(n-2)*(n-2)!=(n-2)!*(n-n-1)(mod n)=(n-2)!*(n-1)(注 -1%n=n-1)......

可得 S = n-1 

#include <cstdio>

int main()
{
    int t;
    long long n;
    
    scanf("%d",&t);
    while(t--){
        scanf("%lld",&n);
        printf("%lld\n",n-1);
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/DADDY_HONG/article/details/82291883