JAVA 购物车

购物车

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

各位亲爱的小伙伴们,大家好!

欢迎来到美美自助购物商场,首先请您帮忙建立商品信息,然后选购商品、确定数量,计算出总价格到结算中心进行结算。美美祝您购物愉快噢!

首先读取N行商品信息,每行包含:商品编号、商品名称、生产商、商品价格、库存数量;

接着输入M行购买信息:商品编号、商品数量、购买标志。

输出购物车中的商品数量T,以及T种商品的详细信息(商品编号、商品名称、生产商、商品价格、库存数量)、实际购买数量和购物车商品总价格(保留2位小数)。

美美商场友情提示:商品数量充分时,您才能购买;另外,您购物成功后,一定要记得增减商品库存数量噢!

Input

首行是商品种类的数量N;

接下来是N行的商品信息,每行商品信息为:商品编号、商品名称、生产商、商品价格、库存数量;

购物操作的次数M;

接下来是M行的商品购买操作的信息,每行购买信息为:商品编号、购买数量count(count>0)、购买标志(1--购买,购物车中该商品数量增加;2--退货,购物车中该商品数量减少,3-删除商品,删除操作时count列的值无效)。

Output

购物车中商品的数量T;

扫描二维码关注公众号,回复: 3373093 查看本文章

购物车中的所有商品详情,每种商品详情占一行,中间数据用1个空格符隔开。商品详情包括:商品编号、商品名称、生产商、商品价格、商品最新库存数量、已购买的商品数量。(商品价格保留2位小数),按照商品编号从小到大的顺序进行输出。若T=0,则无商品详情信息输出。

最后一行输出购物车中商品的总价格。(保留2位小数)

Sample Input

5
1 运动鞋  Adidas  300.80   10
2 蓝球服  李宁    268.00    10
3 苹果    栖霞    5.00	     500
4 智能手表  苹果  4888.00   10
5 鼠标   罗技     120.00    50
9
1 5 1
3 5 1
4 1 1
3 2 2
5 2 1 
1 2 1
5 0 3
3 1 1
3 5 2

Sample Output

2
1 运动鞋 Adidas 300.80 3 7
4 智能手表 苹果 4888.00 9 1
6993.60

Hint

1、购买商品的实际数量要小于或等于库存数量,退货时的数量要小于购物车中该商品的现有数量。

2、购买行为发生时,注意库存的变化。购买商品之后减库存,退货之后加库存。

3、购物车中某商品的实际数量为0时,就移除它。


import java.util.*;
class Customer{
	int id, store, count;
	double price;
	String name, address;
	Customer(){
		
	}
	public Customer(int id, int store, int count, double price, String name, String address) {
		this.id = id;
		this.store = store;
		this.count = count;
		this.price = price;
		this.name = name;
		this.address = address;
	}
}
public class Main {
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		int n = cin.nextInt();
		Customer customer[] = new Customer[n];
		for(int i = 0; i < n; i++) {
			int id = cin.nextInt();
			String name = cin.next();
			String address = cin.next();
			double price = cin.nextDouble();
			int store = cin.nextInt();
			customer[i] = new Customer(id, store, 0, price, name, address);
		}
		int m = cin.nextInt();
		for(int i = 0; i < m; i++) {
			int id = cin.nextInt();
			int count = cin.nextInt();
			int flag = cin.nextInt();
			for(int j = 0; j < n; j++) {
				if(customer[j].id == id) {
					if(flag == 1) {
						if(count <= customer[j].store) {//如果购买数量小于库存
							customer[j].store -= count;
							customer[j].count += count;
						}
						else {//如果购买数量大于库存,只能购买库存的数量,库存变为0
							customer[j].count += customer[j].store;
							customer[j].store = 0;
						}
					}
					else if(flag == 2) {
						if(count <= customer[j].count) {//如果退货数量小于库存
							customer[j].store += count;
							customer[j].count -= count;
						}
						else {//如果退货数量大于购物车数量,只能退购物车的数量,购物车数量变为0
							customer[j].store += customer[j].count;
							customer[j].count = 0;
						}
					}
					else if(flag == 3) {
						customer[j].store += customer[j].count;//购物车数量全部加到库存
						customer[j].count = 0;//购物车数量变为0
					}
					break;
				}
			}
		}
		double sum = 0;
		for(int i = 0; i < n; i++) {
			if(customer[i].count == 0) {//将购物车数量为0的删除掉
				for(int j = i; j < n - 1; j++) {
					customer[j] = customer[j+1];
				}
				i--;
				n--;
			}
			else {
				sum += customer[i].price * customer[i].count;
			}
		}
		for(int i = 0; i < n; i++) {//排序
			for(int j = i + 1; j < n; j++) {
				if(customer[i].id > customer[j].id) {
					Customer a = new Customer();
					a = customer[i];
					customer[i] = customer[j];
					customer[j] = a;
				}
			}
		}
		System.out.println(n);
		for(int i = 0; i < n; i++) {
		System.out.printf("%d %s %s %.2f %d %d\n",customer[i].id, customer[i].name, customer[i].address, customer[i].price, customer[i].store, customer[i].count);
		}
		System.out.printf("%.2f", sum);
		
	}
}




猜你喜欢

转载自blog.csdn.net/Joywss/article/details/80030020
今日推荐