Java练习 SDUT-3328_JAVA判断合法标识符

JAVA判断合法标识符

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

输入若干行字符串,判断每行字符串是否可以作为JAVA语法的合法标识符。 判断合法标识符的规则:由字母、数字、下划线“_”、美元符号“$”组成,并且首字母不能是数字。

Input

输入有多行,每行一个字符串,字符串长度不超过10个字符,以EOF作为结束。

Output

若该行字符串可以作为JAVA标识符,则输出“true”;否则,输出“false”。

Sample Input

abc
_test
$test
a 1
a+b+c
a’b
123
变量

Sample Output

true
true
true
false
false
false
false
true

这道题会用到Java里特有的两个函数

Character.isJavaIdentifierStart();//判断是否符合标识符开头;
Character.isJavaIdentifierPart();//判断是否符合其他部分;

括号填字符

import java.util.*;

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        String s;
        int i;
        boolean f;
        while(cin.hasNextLine())
        {
            s = cin.nextLine();
            f = Character.isJavaIdentifierStart(s.charAt(0));
            if(f==true)
            {
                for(i=1;i<s.length()&&f==true;i++)
                    f = Character.isJavaIdentifierPart(s.charAt(i));
            }
            System.out.println(f);
        }
        cin.close();
    }
}

猜你喜欢

转载自www.cnblogs.com/luoxiaoyi/p/9706327.html