银行业务队列简单模拟

版权声明:沃斯里德小浩浩啊 https://blog.csdn.net/Healer66/article/details/82808366

7-3 银行业务队列简单模拟 (25 分)

设某银行有A、B两个业务窗口,且处理业务的速度不一样,其中A窗口处理速度是B窗口的2倍 —— 即当A窗口每处理完2个顾客时,B窗口处理完1个顾客。给定到达银行的顾客序列,请按业务完成的顺序输出顾客序列。假定不考虑顾客先后到达的时间间隔,并且当不同窗口同时处理完2个顾客时,A窗口顾客优先输出。

输入格式:

输入为一行正整数,其中第1个数字N(≤1000)为顾客总数,后面跟着N位顾客的编号。编号为奇数的顾客需要到A窗口办理业务,为偶数的顾客则去B窗口。数字间以空格分隔。

输出格式:

按业务处理完成的顺序输出顾客的编号。数字间以空格分隔,但最后一个编号后不能有多余的空格。

输入样例:

8 2 1 3 9 4 11 13 15

输出样例:

1 3 2 9 11 4 13 15

原理很简单:两个奇数,一个偶数的顺序输出。 

#include <bits/stdc++.h>
using namespace std;
queue<int> q1,q2;
typedef long long ll;
int a[2000];
int main()
{
    int n;
    cin>>n;
    for(int i=0; i<n; i++)
    {
        cin>>a[i];
        if(a[i]&1)
            q1.push(a[i]);
        else
            q2.push(a[i]);
    }
    int flag=1,first=1;
    while(!q1.empty()&&!q2.empty())
    {
        if(flag)
        {
            if(first)
            {
                cout<<q1.front();
                first=0;

            }
            else
                cout<<' '<<q1.front();
            q1.pop();
            if(q1.empty())
                break;
            cout<<' '<<q1.front();
            flag=0;
            q1.pop();
        }
        else
        {
            if(first)
            {
                cout<<q2.front();
                first=0;
            }
            else
                cout<<' ' <<q2.front();
            q2.pop();
            flag=1;
        }
    }
    while(!q1.empty())
    {
        if(first)
        {
            cout<<q1.front();
            first=0;
        }
        else
            cout<<' '<<q1.front();
        q1.pop();
    }
    while(!q2.empty())
    {
        if(first)
        {
            cout<<q2.front();
            first=0;
        }
        else
            cout<<' '<<q2.front();
        q2.pop();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Healer66/article/details/82808366