1032 挖掘机技术哪家强 (结构体数组初始化)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/LightInDarkness/article/details/82810915

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第 1 行给出不超过 10​5​​ 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

       很简单的一个题目,不过在网上看了一个结构体数组初始化的方法,觉得很好,所以把代码贴上来。这里使用了构造函数,如果初始化为0,也可以用memset。当然啦,还有其他的方法,暂时就不补充了。

#include<iostream>

using namespace std;

struct Node{
	int score;
	int flag;
	Node(){
		score = 0;
		flag = 0;
	}
};

int main(){
	Node nodes[100001];
	int N, school, score, max = 0, index = 0;
	cin >> N;
	for(int i = 0; i < N; i++){
		cin >> school >> score;
		nodes[school].score += score;
		nodes[school].flag = 1;
	}
	for(int i = 0; i < 100001; i++){
		if(nodes[i].flag == 1 && nodes[i].score > max){
			max = nodes[i].score;
			index = i;
		}
	}
	cout << index << ' ' << nodes[index].score;
}

猜你喜欢

转载自blog.csdn.net/LightInDarkness/article/details/82810915