PAT(A) - 1088 Rational Arithmetic(20) -- 分数经典例题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/it2153534/article/details/82431818

1088 Rational Arithmetic(20)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

大致题意:两个分数计算它们的和、差、积、商。要求:负数得有括号、写成带分数、除法时分母为0,商为Inf。

看起来是个简单题,GCD肯定是不能少的,一步步写下去能写100多行,故学习大神0kk470、精品代码参考如下:

#include<iostream>
using namespace std;
typedef long long ll;

ll a,b,c,d,gcdvalue;

ll gcd(ll a,ll b)
{
    return b == 0?abs(a):gcd(b,a % b);
}

string stringFormat(ll a,ll b)
{
    string res = "";
    gcdvalue = gcd(a,b);
    a /= gcdvalue;
    b /= gcdvalue;
    if(a * b < 0)
        res += "(-";
    ll c = abs(a), d = abs(b);
    if(c/d == 0)
    {
       if( c % d == 0)
         res += "0";
       else
         res += to_string(c) + "/" +to_string(d);
    }
    else
    {
       res += to_string(c/d);
       if(c % d != 0)
       {
           res += " " + to_string(c % d) + "/" +to_string(d);
       }
    }
    if(a * b < 0)
        res += ")";
    return res;
}

int main()
{
    scanf("%lld/%lld %lld/%lld",&a,&b,&c,&d);
    ll sum1,sum2,sub1,sub2,mul1,mul2,div1,div2;
    //sum
    sum1 = a * d + b * c;
    sum2 = b * d;
    sub1 = a * d - b * c;
    sub2 = b * d;
    mul1 = a * c;
    mul2 = b * d;
    div1 = a * d;
    div2 = b * c;
    string a1 = stringFormat(a,b);
    string a2 = stringFormat(c,d);
    cout << a1 << " + " << a2 <<" = " << stringFormat(sum1,sum2) << endl;
    cout << a1 << " - " << a2 <<" = " << stringFormat(sub1,sub2) << endl;
    cout << a1 << " * " << a2 <<" = " << stringFormat(mul1,mul2) << endl;
    if(a2 != "0")
     cout << a1 << " / " << a2 <<" = " << stringFormat(div1,div2) << endl;
    else
     cout << a1 << " / " << a2 <<" = " << "Inf" << endl;
}

来源:https://www.cnblogs.com/0kk470/p/7874391.html

猜你喜欢

转载自blog.csdn.net/it2153534/article/details/82431818