连连看(DFS模板)

Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。 
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。 

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。 
注意:询问之间无先后关系,都是针对当前状态的! 

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。 

Sample Input

3 4

1 2 3 4

0 0 0 0

4 3 2 1

4

1 1 3 4

1 1 2 4

1 1 3 3

2 1 2 4

3 4

0 1 4 3

0 2 4 1

0 0 0 0

2

1 1 2 4

1 3 2 3

0 0

Sample Output

YES

NO

NO

NO

NO

YES

Code:

#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<map>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#define mod 998244353
#define Max 0x3f3f3f3f
#define Min 0xc0c0c0c0
#define mst(a) memset(a,0,sizeof(a))
#define f(i,a,b) for(int i=a;i<b;i++)
using namespace std;
typedef long long ll;
const int INF=0xfffff;
const int maxn=1005;
const int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int arr[maxn][maxn];
int vis[maxn][maxn];
int n,m,q,x1,y1,x2,y2;
bool flag;
int inbound(int temp1,int temp2)
{
    return (temp1>=1 && temp1<=n && temp2>=1 && temp2<=m && (arr[temp1][temp2]==0 || temp1==x2 && temp2==y2));
}
void dfs(int x,int y,int val,int t)
{
    if(x==x2 && y==y2)
    {
        flag=1;
        return ;
    }
    for(int i=0;i<4 && flag==0;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx>=1 && xx<=n && yy>=1 && y<=m && (arr[xx][yy]==0 || xx==x2 && yy==y2))
        {
            if(i==t || t==-1)
            {
                vis[xx][yy]=val;
                dfs(xx,yy,val,i);
                if(flag==1)
                {
                    return ;
                }
            }
            else if(val<2 && vis[xx][yy]>vis[x][y])
            {
                vis[xx][yy]=val+1;
                dfs(xx,yy,val+1,i);
                if(flag==1)
                {
                    return;
                }
            }
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        if(n==0 && m==0)
        {
            break;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin>>arr[i][j];
            }
        }
        cin>>q;
        while(q--)
        {
            flag=0;
            cin>>x1>>y1>>x2>>y2;
            if(arr[x1][y1]!=arr[x2][y2])
            {
                cout<<"NO"<<endl;
            }
            else if(arr[x1][y1]==0)
            {
                cout<<"NO"<<endl;
            }
            else
            {
                fill(&vis[0][0],&vis[maxn][0],Min);
                vis[x1][y1]=0;
                dfs(x1,y1,0,-1);
                if(flag==1)
                {
                    cout<<"YES"<<endl;
                }
                else
                {
                    cout<<"NO"<<endl;
                }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq1013459920/article/details/82354259