PAT甲级1010 (进制和二分法)

题目

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is “yes”, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number “radix” is the radix of N1 if “tag” is 1, or of N2 if “tag” is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print “Impossible”. If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible


题解:
一开始不了解tag的意思,看到if那句话,明白了它只能是1或2。radix就是N tag的进制数。一开始想的是,把未知进制的数转化成和已知进制数相同的进制,但这样操作难度很高,不如全转化为10进制。

本题还有一个重点是,并不会因为每一位取0~35而使得输入数最大为36进制,进制可能超大,所以用long long radix。

未知进制数,最小进制是它最大的数字+1,因为要和已知进制的数相等,所以最大进制是已知进制数的进制。假设例子里N2为6进制的010,化为10进制就是6=N1。进制数再大化为10进制一定超过6了。

#include <iostream>
#include <cctype>
#include <algorithm>
#include <cmath>
using namespace std;
long long convert(string n, long long radix) {
    long long sum = 0;
    int index = 0;
    int s[11];
   for(int i=n.length()-1;i>=0;i--){
     if('0'<=n[i]&&n[i]<='9')
      s[i]=n[i]-'0';
      else
      s[i]=n[i]-'a'+10;
    sum+=s[i]*pow(radix,index++);
     
   }
    return sum;
}
long long find_radix(string n, long long num) {
    char it = *max_element(n.begin(), n.end());
    long long low = (isdigit(it) ? it - '0': it - 'a' + 10) + 1;
    long long high = max(num, low);
    while (low <= high) {
        long long mid = (low + high) / 2;
        long long t = convert(n, mid);
        if (t < 0 || t > num) high = mid - 1;
        else if (t == num) return mid;
        else low = mid + 1;
    }
    return -1;
}
int main() {
    string n1, n2;
    long long tag = 0, radix = 0, result_radix;
    cin >> n1 >> n2 >> tag >> radix;
    result_radix = tag == 1 ? find_radix(n2, convert(n1, radix)) : find_radix(n1, convert(n2, radix));
    if (result_radix != -1) {
        printf("%lld", result_radix);
    } else {
        printf("Impossible");
    }   
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_24572475/article/details/82795913
今日推荐