C ++ STL队列应用

7-18 银行业务队列简单模拟 (25 分)

设某银行有A、B两个业务窗口,且处理业务的速度不一样,其中A窗口处理速度是B窗口的2倍 —— 即当A窗口每处理完2个顾客时,B窗口处理完1个顾客。给定到达银行的顾客序列,请按业务完成的顺序输出顾客序列。假定不考虑顾客先后到达的时间间隔,并且当不同窗口同时处理完2个顾客时,A窗口顾客优先输出。

输入格式:

输入为一行正整数,其中第1个数字N(≤1000)为顾客总数,后面跟着N位顾客的编号。编号为奇数的顾客需要到A窗口办理业务,为偶数的顾客则去B窗口。数字间以空格分隔。

输出格式:

按业务处理完成的顺序输出顾客的编号。数字间以空格分隔,但最后一个编号后不能有多余的空格。

输入样例:

8 2 1 3 9 4 11 13 15

输出样例:

1 3 2 9 11 4 13 15
#include<iostream>
#include<queue>
using namespace std;


int main()
{
	queue<int> a, b;
	int n, temp, number = 0;
	int flag = 1;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> temp;
		if (temp % 2)
		{
			a.push(temp);
		}
		else
		{
			b.push(temp);
		}
	}
	while (!a.empty() || !b.empty())
	{
		if (!a.empty())
		{
			if (flag)
			{
				printf("%d", a.front());
				flag = 0;
			}
			else
				printf(" %d", a.front());
			a.pop();
		}
		if (!a.empty())
		{
			printf(" %d", a.front());
			a.pop();
		}
		if (!b.empty())
		{
			if (flag)
			{
				printf("%d", b.front());
				flag = 0;
			}
			else
				printf(" %d", b.front());
			b.pop();
		}

		
	}
}

猜你喜欢

转载自blog.csdn.net/wwxy1995/article/details/82804839