1066. 图像过滤(15)--PAT乙级真题java实现

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/JingLisen/article/details/82557026

个人博客:小景哥哥

1066. 图像过滤(15)–PAT乙级真题java实现

图像过滤是把图像中不重要的像素都染成背景色,使得重要部分被凸显出来。现给定一幅黑白图像,要求你将灰度值位于某指定区间内的所有像素颜色都用一种指定的颜色替换。
输入格式:
输入在第一行给出一幅图像的分辨率,即两个正整数M和N(0 < M, N <= 500),另外是待过滤的灰度值区间端点A和B(0 <= A < B <= 255)、以及指定的替换灰度值。随后M行,每行给出N个像素点的灰度值,其间以空格分隔。所有灰度值都在[0, 255]区间内。
输出格式:
输出按要求过滤后的图像。即输出M行,每行N个像素灰度值,每个灰度值占3位(例如黑色要显示为000),其间以一个空格分隔。行首尾不得有多余空格。
输入样例:
3 5 100 150 0
3 189 254 101 119
150 233 151 99 100
88 123 149 0 255
输出样例:
003 189 254 000 000
000 233 151 099 000
088 000 000 000 255


import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) throws IOException{
        Scanner sc = new Scanner(System.in);
        int M = sc.nextInt(), N = sc.nextInt(), A = sc.nextInt(), B = sc.nextInt(), filter = sc.nextInt();
        for(int i = 0; i < M; i++) {
            for(int j = 0; j < N; j++) {
                int rgb = sc.nextInt();
                if(rgb >= A && rgb <= B) {
                    rgb = filter;
                }
                if(j != 0)
                    System.out.print(" ");
                System.out.printf("%03d",rgb);
            }
            System.out.println();
        }

    }
}
/**
 * solution tow
 * @param args
 * @throws IOException
 */
class solution{
    public static void main(String[] args) throws IOException{
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] s = br.readLine().split(" ");
        int M = Integer.parseInt(s[0]), N = Integer.parseInt(s[1]),
                A = Integer.parseInt(s[2]), B = Integer.parseInt(s[3]),
                filter = Integer.parseInt(s[4]);
        for(int i = 0; i < M; i++) {
            String[] sp = br.readLine().split(" ");
            for(int j = 0; j < N; j++) {
                int rgb = Integer.parseInt(sp[j]);
                if(rgb >= A && rgb <= B) {
                    rgb = filter;
                }
                if(j != 0)
                    System.out.print(" ");
                System.out.printf("%03d",rgb);
            }
            System.out.println();
        }
    }
}

猜你喜欢

转载自blog.csdn.net/JingLisen/article/details/82557026