PAT (Advanced Level) Practice 1119 Pre- and Post-order Traversals(30 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Puppettt/article/details/82251681

1119 Pre- and Post-order Traversals(30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

题意:给你前序遍历和后序遍历,它的中序遍历是否唯一。输出中序遍历(不唯一则输出任意一种情况)

思路:主要判断当前序和后序遍历某个子树只剩两个节点(根结点和一个孩子结点)时,这个孩子节点可以是左儿子,也可以说右儿子。这时不唯一。

代码: 

#include <bits/stdc++.h>
using namespace std;
const int maxn=31;
int pre[maxn],post[maxn],flag=0,space;
struct node{
    int v,left,right;
}a[maxn];
//左右不分 默认放左
int in(int pr_l,int pr_r,int pos_l,int pos_r)
{
    if(pr_l>pr_r)return 0;
    if(pr_l==pr_r)return pre[pr_l];

    if(pr_l+1==pr_r)
    {
        if(pre[pr_l]==post[pos_r]&&pre[pr_r]==post[pos_l])flag=0;
    }
    int root=pre[pr_l]; //先序遍历 第一个是根结点
    int l=pre[pr_l+1];
    int pos_root=pos_l;
    //找左子树的根结点位置
    while(post[pos_root]!=l)pos_root++;
    int cnt=pos_root-pos_l;//与左边界 间隔个数
   
    a[root].left=in(pr_l+1,pr_l+1+cnt,pos_l,pos_root);
    a[root].right=in(pr_l+cnt+2,pr_r,pos_root+1,pos_r-1);
    return root;
}
void intra(int x)
{

    if(a[x].left)intra(a[x].left);
    if(space)printf(" ");
    printf("%d",x);space++;
    if(a[x].right)intra(a[x].right);

}
int main()
{
    int n;scanf("%d",&n);
    for(int i=0;i<n;i++)scanf("%d",&pre[i]);
    for(int i=0;i<n;i++)scanf("%d",&post[i]);
    flag=1;
    in(0,n-1,0,n-1);

    if(flag)printf("Yes\n");
    else printf("No\n");
    space=0;
    intra(pre[0]);

    printf("\n");
}

猜你喜欢

转载自blog.csdn.net/Puppettt/article/details/82251681