1060 Are They Equal

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10
​5
​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10
​100
​​ , and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9
Sample Output 1:

YES 0.123*10^5
Sample Input 2:

3 120 128
Sample Output 2:

NO 0.120*10^3 0.128*10^3

扫描二维码关注公众号,回复: 3193496 查看本文章

参考代码:

#include<iostream>
#include<string>

using namespace std;
int n;
string convert(const string &s, int & exp)
{
    int cnt = s.size(), p = 0;
    for (int i = 0; i < s.size(); i++) {
        if (s[i] == '.') {
            cnt = i;
            break;
        }
    }
    while (s[p] == '0' || s[p] == '.')p++;
    if (cnt>=p) {
        cnt=cnt-p;
    }
    else cnt = cnt - p + 1;
    if (p == s.size())cnt = 0;
    int index = 0;
    string num;
    while (index<n) {
        if (p < s.size() && s[p] != '.')
        {
            num += s[p];
            index++;
        }
        else if (p >= s.size())
        {
            num += '0';
            index++;
        }
        p++;
    }
    exp = cnt;
    return num;
}
int main()
{
    string a, b;
    cin >> n >> a >> b;
    string sa, sb;
    int na, nb;
    sa = convert(a, na);
    sb = convert(b, nb);
    if (sa == sb && na == nb) {
        cout << "YES 0." << sa << "*10^" << na;
    }
    else cout << "NO " << "0." << sa << "*10^" << na << " 0." << sb << "*10^" << nb;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82055004