UPC 组队训练 A: Taro's Shopping

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a17865569022/article/details/82315833

问题 A: Taro’s Shopping
时间限制: 1 Sec 内存限制: 128 MB
提交: 75 解决: 63
[提交] [状态] [讨论版] [命题人:admin]
题目描述
Mammy decided to give Taro his first shopping experience. Mammy tells him to choose any two items he wants from those listed in the shopping catalogue, but Taro cannot decide which two, as all the items look attractive. Thus he plans to buy the pair of two items with the highest price sum, not exceeding the amount Mammy allows. As getting two of the same item is boring, he wants two different items.

You are asked to help Taro select the two items. The price list for all of the items is given. Among pairs of two items in the list, find the pair with the highest price sum not exceeding the allowed amount, and report the sum. Taro is buying two items, not one, nor three, nor more. Note that, two or more items in the list may be priced equally.

输入
The input consists of multiple datasets, each in the following format.
n m
a1 a2 … an
A dataset consists of two lines. In the first line, the number of items n and the maximum payment allowed m are given. n is an integer satisfying 2 ≤ n ≤ 1000. m is an integer satisfying 2 ≤ m ≤ 2,000,000. In the second line, prices of n items are given. ai (1 ≤ i ≤ n) is the price of the i-th item. This value is an integer greater than or equal to 1 and less than or equal to 1,000,000.
The end of the input is indicated by a line containing two zeros. The sum of n’s of all the datasets does not exceed 50,000.

输出
For each dataset, find the pair with the highest price sum not exceeding the allowed amount m and output the sum in a line. If the price sum of every pair of items exceeds m, output NONE instead.

样例输入
3 45
10 20 30
6 10
1 2 5 8 9 11
7 100
11 34 83 47 59 29 70
4 100
80 70 60 50
4 20
10 5 10 16
0 0

样例输出
40
10
99
NONE
20

#include<bits/stdc++.h>
using namespace std;
int num[1005];
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        sort(num,num+n,cmp);
        int b;int flag=0;int Max=-1;
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                b=num[j]+num[i];
                if(b<=m)
                {
                    flag=1;
                    //cout<<Max<<" "<<b<<endl;
                    Max=max(Max,b);
                }
            }
        }
        if(flag==0)
            printf("NONE\n");
        else
            printf("%d\n",Max);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/82315833