2018 ACM-ICPC南京网络赛 Lpl and Energy-saving Lamps(线段树)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/GYH0730/article/details/82289647

During tea-drinking, princess, amongst other things, asked why has such a good-natured and cute Dragon imprisoned Lpl in the Castle? Dragon smiled enigmatically and answered that it is a big secret. After a pause, Dragon added:

— We have a contract. A rental agreement. He always works all day long. He likes silence. Besides that, there are many more advantages of living here in the Castle. Say, it is easy to justify a missed call: a phone ring can't reach the other side of the Castle from where the phone has been left. So, the imprisonment is just a tale. Actually, he thinks about everything. He is smart. For instance, he started replacing incandescent lamps with energy-saving lamps in the whole Castle...

Lpl chose a model of energy-saving lamps and started the replacement as described below. He numbered all rooms in the Castle and counted how many lamps in each room he needs to replace.

At the beginning of each month, Lpl buys mm energy-saving lamps and replaces lamps in rooms according to his list. He starts from the first room in his list. If the lamps in this room are not replaced yet and Lpl has enough energy-saving lamps to replace all lamps, then he replaces all ones and takes the room out from the list. Otherwise, he'll just skip it and check the next room in his list. This process repeats until he has no energy-saving lamps or he has checked all rooms in his list. If he still has some energy-saving lamps after he has checked all rooms in his list, he'll save the rest of energy-saving lamps for the next month.

As soon as all the work is done, he ceases buying new lamps. They are very high quality and have a very long-life cycle.

Your task is for a given number of month and descriptions of rooms to compute in how many rooms the old lamps will be replaced with energy-saving ones and how many energy-saving lamps will remain by the end of each month.

Input

Each input will consist of a single test case.

The first line contains integers nn and m (1 \le n \le 100000, 1 \le m \le 100)m(1≤n≤100000,1≤m≤100) — the number of rooms in the Castle and the number of energy-saving lamps, which Lpl buys monthly.

The second line contains nn integers k_1, k_2, ..., k_nk1​,k2​,...,kn​
(1 \le k_j \le 10000, j = 1, 2, ..., n)(1≤kj​≤10000,j=1,2,...,n) — the number of lamps in the rooms of the Castle. The number in position jjis the number of lamps in jj-th room. Room numbers are given in accordance with Lpl's list.

The third line contains one integer q (1 \le q \le 100000)q(1≤q≤100000) — the number of queries.

The fourth line contains qq integers d_1, d_2, ..., d_qd1​,d2​,...,dq​
(1 \le d_p \le 100000, p = 1, 2, ..., q)(1≤dp​≤100000,p=1,2,...,q) — numbers of months, in which queries are formed.

Months are numbered starting with 11; at the beginning of the first month Lpl buys the first m energy-saving lamps.

Output

Print qq lines.

Line pp contains two integers — the number of rooms, in which all old lamps are replaced already, and the number of remaining energy-saving lamps by the end of d_pdp​ month.

Hint

Explanation for the sample:

In the first month, he bought 44 energy-saving lamps and he replaced the first room in his list and remove it. And then he had 11 energy-saving lamps and skipped all rooms next. So, the answer for the first month is 1,1------11,1−−−−−−1 room's lamps were replaced already, 11 energy-saving lamp remain.

样例输入复制

5 4
3 10 5 2 7
10
5 1 4 8 7 2 3 6 4 7

样例输出复制

4 0
1 1
3 6
5 1
5 1
2 0
3 2
4 4
3 6
5 1

离线一下,暴力枚举,用线段树维护区间不小于val第一次出现的那个数

#include <bits/stdc++.h>
#define lson num << 1
#define rson num << 1 | 1
using namespace std;
const int MAXN = 100005;
const int INF = 0x3f3f3f3f;
struct node
{
    int l,r,Min;
}tree[MAXN << 2];
int Q[MAXN],a[MAXN],QQ[MAXN];
bool vis[MAXN];
int cur;
struct node2
{
    int ans1,ans2;
}ans[MAXN];
void pushup(int num)
{
    tree[num].Min = min(tree[lson].Min,tree[rson].Min);
}
void build(int num,int l,int r)
{
    tree[num].l = l;
    tree[num].r = r;
    if(l == r) {
        tree[num].Min = a[l];
        return;
    }
    int mid = (l + r) >> 1;
    build(lson,l,mid);
    build(rson,mid + 1,r);
    pushup(num);
}
void query(int num,int l,int r,int val)
{
    if(tree[num].l == tree[num].r) {
        if(tree[num].Min <= val) cur = min(cur,tree[num].l);
        return;
    }
    int mid = (tree[num].l + tree[num].r) >> 1;
    if(tree[num].l == l && tree[num].r == r) {
        if(tree[lson].Min <= val) query(lson,l,mid,val);
        else if(tree[rson].Min <= val) query(rson,mid + 1,r,val);
        return;
    }
    if(r <= mid) query(lson,l,r,val);
    else if(l > mid) query(rson,l,r,val);
    else {
        query(lson,l,mid,val);
        query(rson,mid + 1,r,val);
    }
}
void update(int num,int pos)
{
    if(tree[num].l == tree[num].r) {
        tree[num].Min = INF;
        return;
    }
    int mid = (tree[num].l + tree[num].r) >> 1;
    if(pos <= mid) update(lson,pos);
    else update(rson,pos);
    pushup(num);
}
int main(void)
{
    int n,m,q,temp,cnt,mm,L,cntt;
    while(scanf("%d %d",&n,&m) != EOF) {
        memset(vis,false,sizeof(vis));
        for(int i = 1; i <= n; i++) scanf("%d",&a[i]);
        build(1,1,n);
        scanf("%d",&q);
        cnt = 0;
        for(int i = 1; i <= q; i++) {
            scanf("%d",&QQ[i]);
            if(vis[QQ[i]]) continue;
            else {
                vis[QQ[i]] = true;
                Q[cnt++] = QQ[i];
            }
        }
        sort(Q,Q + cnt);
        mm = m;
        cntt = 0;
        int pos = n;
        int flag = 0;
        for(int i = 1; i <= Q[cnt - 1]; i++) {
            cur = n + 1;
            L = 1;
            if(flag) {
                ans[i].ans1 = cntt;
                ans[i].ans2 = mm;
            }
            else {
                while(1) {
                    cur = n + 1;
                    query(1,L,n,mm);
                    if(cur == n + 1) break;
                    cntt++;
                    update(1,cur);
                    mm -= a[cur];
                    L = cur + 1;
                    if(cur == n) break;
                }
                ans[i].ans1 = cntt;
                ans[i].ans2 = mm;
            }
            if(cntt >= n) {
                flag = 1;
            }
            else mm += m;
        }
        for(int i = 1; i <= q; i++) {
            printf("%d %d\n",ans[QQ[i]].ans1,ans[QQ[i]].ans2);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GYH0730/article/details/82289647
今日推荐