POJ 2449 Remmarguts' Date(第k短路模板)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37025443/article/details/82556101

Remmarguts' Date

题目链接

Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 36964   Accepted: 10188

Description

"Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he told them a story. 

"Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission." 

"Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)" 

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister's help! 

DETAILS: UDF's capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince' current place. M muddy directed sideways connect some of the stations. Remmarguts' path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate. 

Input

The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T. 

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).

Output

A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output "-1" (without quotes) instead.

Sample Input

2 2
1 2 5
2 1 4
1 2 2

Sample Output

14

题意:

让你求从s到e的第k短路,输出长度

解析:

第k短路

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <functional>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAXN = 1e3+10;
const int MAXM = 1e5+10;
typedef long long ll;
int vis[MAXN];
int low[MAXN];
int head[MAXN],head1[MAXN];
int from,to;
int tot;
int n,m,k;
struct edge
{
    int u,v;
    int len;
    int next;       //正向
    int next1;      //反向
    edge() {}
    edge(int x,int y,int c):u(x),v(y),len(c) {}
};
edge p[MAXM];

struct node
{
    int po;
    int g,h;
    node() {}
    node(int x,int y,int z):po(x),g(y),h(z) {}
    bool operator<(const node& a)const
    {
        return g+h>a.g+a.h;
    }
};

void add_edge(int u,int v,int c)
{
    p[tot] = edge(u,v,c);
    p[tot].next = head[u];
    head[u] = tot;
    p[tot].next1 = head1[v];
    head1[v] = tot++;
}

void Dij(int c)       //从to开始找出所有点到to的最短路
{
    priority_queue<node>que;
    memset(vis,0,sizeof(vis));
    for(int i = 1; i <= n; i++)
        low[i] = INF;
    low[c] = 0;
    que.push(node(c,0,0));
    while(!que.empty())
    {
        node cur = que.top();
        que.pop();
        if(vis[cur.po])
            continue;
        vis[cur.po] = 1;
        for(int i = head1[cur.po]; ~i; i = p[i].next1)       //反向查找
        {
            if(low[p[i].u] > low[cur.po]+p[i].len)
            {
                low[p[i].u] = low[cur.po] + p[i].len;
                que.push(node(p[i].u,0,low[p[i].u]));
            }
        }
    }
}


int bfs(int t)
{
    int num = 0;
    priority_queue<node>que;
    node cur;
    cur.po = t;
    cur.g = 0;
    que.push(cur);
    while(!que.empty())
    {
        cur = que.top();
        que.pop();
        int tp = cur.po;
        if(tp == to)
        {
            num ++;
            if(num == k)
            {
                return cur.g;
            }
        }
        for(int i = head[cur.po]; ~i; i = p[i].next)
        {
            node tmp;
            int x = p[i].v;
            tmp.po = x;
            tmp.g = cur.g + p[i].len;
            tmp.h = low[x];
            que.push(tmp);
        }
    }
    return -1;
}

void ini()
{
    tot = 0;
    memset(head,-1,sizeof(head));
    memset(head1,-1,sizeof(head1));
}

int solve()
{
    Dij(to);
    if(low[from] == INF)   //如果from不能到达to
    {
        return -1;
    }
    if(from == to)
    {
        k++;
    }
    int ans=bfs(from);
    return ans;
}

int main()
{
    int a,b,len;
    int t;
    while(scanf("%d%d",&n,&m) != EOF)
    {
        ini();

        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d",&a,&b,&len);
            add_edge(a,b,len);
        }
        scanf("%d%d%d",&from,&to,&k);
        printf("%d\n",solve());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37025443/article/details/82556101