【HDU6447】YJJ's Salesman(dp+树状数组+离散)

题目链接

YJJ's Salesman

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2046    Accepted Submission(s): 768


 

Problem Description

YJJ is a salesman who has traveled through western country. YJJ is always on journey. Either is he at the destination, or on the way to destination.
One day, he is going to travel from city A to southeastern city B. Let us assume that A is (0,0) on the rectangle map and B (109,109) . YJJ is so busy so he never turn back or go twice the same way, he will only move to east, south or southeast, which means, if YJJ is at (x,y) now (0≤x≤109,0≤y≤109) , he will only forward to (x+1,y) , (x,y+1) or (x+1,y+1) .
On the rectangle map from (0,0) to (109,109) , there are several villages scattering on the map. Villagers will do business deals with salesmen from northwestern, but not northern or western. In mathematical language, this means when there is a village k on (xk,yk) (1≤xk≤109,1≤yk≤109) , only the one who was from (xk−1,yk−1) to (xk,yk) will be able to earn vk dollars.(YJJ may get different number of dollars from different village.)
YJJ has no time to plan the path, can you help him to find maximum of dollars YJJ can get.

 

Input

The first line of the input contains an integer T (1≤T≤10) ,which is the number of test cases.

In each case, the first line of the input contains an integer N (1≤N≤105) .The following N lines, the k -th line contains 3 integers, xk,yk,vk (0≤vk≤103) , which indicate that there is a village on (xk,yk) and he can get vk dollars in that village.
The positions of each village is distinct.

 

Output

The maximum of dollars YJJ can get.

 

Sample Input

 

1

3

1 1 1

1 2 2

3 3 1

 

Sample Output

 

3

 

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

【题意】

如果把左上角定为原点,那么它只能向右或向下或右下走,但是只有往右下走是可以拿到金钱的,问他最多能拿到多少金钱

【解题思路】

终于来补这题了qaq每天催眠自己做题是快乐的,补题是有趣的( 才怪:(  )

因为点的个数实际上是1e5个,但是坐标有1e9,所以首先需要离散化,这里用结构存储横纵坐标,将点离散化到1e5*1e5个。

然后下面的题解应该还是挺清楚的,能够明白。

【代码】

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn=1e5+5;
int y[maxn],n;
LL tree[maxn];
struct Node
{
    int x,y,w;
}node[maxn];
bool cmp(Node a,Node b)
{
    return (a.x==b.x)?a.y>b.y:a.x<b.x;
}
int lowbit(int x)
{
    return x&(-x);
}
void update(int k,LL w)
{
    while(k<=n)
    {
        tree[k]=max(w,tree[k]);
        k+=lowbit(k);
    }
}
LL query(int k)
{
    LL ans=0;
    while(k)
    {
        ans=max(ans,tree[k]);
        k-=lowbit(k);
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(tree,0,sizeof(tree));
        memset(node,0,sizeof(node));
        memset(y,0,sizeof(y));
        LL ans=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&node[i].x,&node[i].y,&node[i].w);
            y[i]=node[i].y;
        }
        sort(y+1,y+1+n);
        sort(node+1,node+1+n,cmp);
        for(int i=1;i<=n;i++)
        {
            int index=lower_bound(y+1,y+1+n,node[i].y)-y;
            LL tmp=query(index-1)+node[i].w;
            ans=max(tmp,ans);
            update(index,tmp);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/82313331