PAT 甲级 1095 Cars on Campus(模拟)

1095 Cars on Campus(30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in accending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

 Analysis:

Simulation.

c++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int stay[10001];//the length of stay time
int record[86401];//re[i] stands for the number of car when at i.
vector<int>v[10001];//store the valid time
int cmp(int a,int b)
{
	return abs(a)<abs(b);
}
int main()
{
	freopen("1095 Cars on Campus.txt","r",stdin);
	int n,q,num=1,maxstay=0,flag=1;
	/*
	before coding,you must know the regulation(according to the case 1)
	when at the arriving time ,the car should be counted,when at the leaving time,the opposite.
	
	*/
	cin>>n>>q;
	map<string ,int>sti;
	for(int i=0;i<n;i++){
		string plate_num,flag;
		int h,m,s,Time;
		cin>>plate_num;
		scanf("%d:%d:%d",&h,&m,&s);
		Time=h*60*60+m*60+s+1;//add 1 to avoid 0(in that case,you can not judge out time or in time according to the sign)
		cin>>flag;
		if(sti[plate_num]==0)//hasn't been visited
			sti[plate_num]=num++;//number the string 
		if(flag[0]=='i')Time=-1*Time;//if negative,it means the in time.
		v[sti[plate_num]].push_back(Time);//v[i][j] means the j-th time(in or out)of the i th string 	
	}
	map<string ,int>::iterator it;
	for(it=sti.begin();it!=sti.end();it++){
		int i=it->second;
		if(v[i].size()>=2){//record the valid time
			sort(v[i].begin(),v[i].end(),cmp);//sort according to the absolute.
			for(int j=1;j<v[i].size();j++)//for every car
				if(v[i][j-1]<0&&v[i][j]>0){//negative means in time ,otherwise out time.
					stay[i]+=v[i][j]+v[i][j-1];
					record[v[i][j]]--;//minus
					record[v[i][j-1]*(-1)]++;//plus 					
				}
			if(stay[i]>maxstay)//caculate the max stay time.
				maxstay=stay[i];					
		}
	}
	for(int i=1;i<86401;i++)// preffix sum
		record[i]+=record[i-1];
	while(q--){//inquire
		int h,m,s;
		scanf("%d:%d:%d",&h,&m,&s);
		int Time=h*60*60+m*60+s+1;
		printf("%d\n",record[Time]);
	}
	for(it=sti.begin();it!=sti.end();it++){
		if(stay[it->second]==maxstay)
			if(flag){
				flag=0;
				cout<<it->first;
			}
			else
				cout<<" "<<it->first;
	}
	printf(" %02d:%02d:%02d",maxstay/3600,maxstay/60%60,maxstay%60); //conversion
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/82317619