[dinic最大流 输出每条边流量] A - ACM Computer Factory POJ - 3436

ACM Computer Factory

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9232   Accepted: 3406   Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part jDi,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.

Source

Northeastern Europe 2005, Far-Eastern Subregion

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int inf = 0x7fffffff;
const int mn = 200, mm = 1e5;

int in[mn][mn], out[mn][mn];
int con[mn][mn];
int edge;
int fr[mn];
int cur[mn];
int lv[mn];
struct node
{
	int to, val, nx, fan;
} e[mm];

void addedge(int u, int v, int w)
{
	edge++;
	e[edge].to = v, e[edge].val = w, e[edge].nx = fr[u], e[edge].fan = edge + 1;
	fr[u] = edge;
	edge++;
	e[edge].to = u, e[edge].val = 0, e[edge].nx = fr[v], e[edge].fan = edge - 1;
	fr[v] = edge;
}

void bfs(int s)
{
	memset(lv, 0, sizeof lv);
	lv[s] = 1;
	queue<int>q;
	q.push(s);
	while (!q.empty())
	{
		int t = q.front();
		q.pop();
		for (int i = fr[t]; i != -1; i = e[i].nx)
		{
			if (e[i].val > 0 && !lv[e[i].to])
			{
				lv[e[i].to] = lv[t] + 1;
				q.push(e[i].to);
			}
		}
	}
}

int dfs(int s, int t, int f)
{
	if (s == t)
		return f;
	for (int &i = cur[s]; i != -1; i = e[i].nx)
	{
		if (e[i].val > 0 && lv[e[i].to] > lv[s])
		{
			int d = dfs(e[i].to, t, min(f, e[i].val));
			if (d > 0)
			{
				e[i].val -= d;
				e[e[i].fan].val += d;
				return d;
			}
		}
	}
	return 0;
}

int max_flow(int s, int t)
{
	int flow = 0;
	while (1)
	{
		bfs(s);
		if (!lv[t])
			break;

		for (int i = 0; i < mn; i++)
			cur[i] = fr[i];

		int f = -1;
		while ((f = dfs(s, t, inf)) > 0)
			flow += f;
	}
	return flow;
}

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("D:\\in.txt", "r", stdin);
	#endif // ONLINE_JUDGE
	
	int p, n;
	while (~scanf("%d %d", &p, &n))
	{
		edge = 0;
		memset(fr, -1, sizeof fr);
		memset(con, 0, sizeof con);
		
		int st = 0, ed = 110;
		for (int i = 1; i <= n; i++)
		{
			int f;
			scanf("%d", &f);
			addedge(i, i + 50, f); // 拆点

			bool f1 = 1, f2 = 1;
			for (int j = 1; j <= p; j++)
			{
				scanf("%d", &in[i][j]);
				if (in[i][j] == 1)  // 需要输入
					f1 = 0;
			}
			for (int j = 1; j <= p; j++)
			{
				scanf("%d", &out[i][j]);
				if (!out[i][j]) // 不全输出
					f2 = 0;
			}
			if (f1)
				addedge(st, i, inf);
			if (f2)
				addedge(i + 50, ed, inf);
		}

		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				if (i == j)
					continue;

				bool flag = 1;
				for (int k = 1; k <= p; k++)
				{
					if (in[j][k] == 2)
						continue;
					if (out[i][k] != in[j][k])
						flag = 0;
				}
				if (flag)
				{
					con[i][j] = edge + 1;
					addedge(i + 50, j, inf);
				}  // 输出和输入相对应的建边
			}
		}

		int res = max_flow(st, ed);
		printf("%d ", res);

		/// 有流量流过 e[i].val减小对应的值
		int sum = 0;
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
				if (con[i][j] && e[con[i][j]].val != inf)
					sum++;
		printf("%d\n", sum);
		
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
				if (con[i][j] && e[con[i][j]].val != inf)
					printf("%d %d %d\n", i, j, inf - e[con[i][j]].val);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81433968