HDU-5025 Saving Tang Monk(广搜+状态)

Saving Tang Monk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3199    Accepted Submission(s): 1116


 

Problem Description

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.

 

Input

There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M).

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.

 

Output

For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).

 

Sample Input

 

3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0

 

Sample Output

 

5 impossible 8

 

Source

2014 ACM/ICPC Asia Regional Guangzhou Online

 

Recommend

hujie

借鉴:https://blog.csdn.net/u011721440/article/details/39433547

#include<math.h>
#include<queue>
#include<string.h>
#include <cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 105
#define INF 0X3f3f3f3f
int dir[4][2]={0,1,1,0,0,-1,-1,0};
char g[N][N];
int e[N][N];
int mark[N][N][11];
int n,m,ans;
struct node
{
    int x,y,t,id,s;   //坐标、时间、钥匙、和杀死的蛇
    friend bool operator<(node a,node b)
    {
        return a.t>b.t;
    }
};
int min(int a,int b)
{
    return a<b?a:b;
}
bool judge(int x,int y)       
{
    if(x<0||x>=n||y<0||y>=n||g[x][y]=='#')
        return true;
    return false;
}
int bfs(int x,int y)
{
    int ans=INF;
    int i,di,dj;
    priority_queue<node>q;
    node cur,next;
    cur.x=x;cur.y=y;
    cur.t=cur.s=0;
    cur.id=0;
    q.push(cur);
    mark[x][y][0]=0;
    while(!q.empty())
    {
        cur=q.top();
        q.pop();
        if(g[cur.x][cur.y]=='T'&&cur.id==m)
        {
            ans=min(ans,cur.t);
            continue;
        }
        for(i=0;i<4;i++)
        {
            next.x=di=cur.x+dir[i][0];
            next.y=dj=cur.y+dir[i][1];
            next.t=cur.t+1;
            next.s=cur.s;
            next.id=cur.id;
            if(judge(di,dj))
                continue;
            if(g[di][dj]=='S')
            {
                int t=e[di][dj];
                if((next.s&(1<<t))==0)  //杀过的蛇今后就不必在杀
                {
                    next.s|=(1<<t);
                    next.t++;
                }
            }
            if(next.id==g[di][dj]-'0'-1) 
            {
                next.id++;
            }
            int t=next.id;
            if(mark[di][dj][t]>next.t)    //mark来存钥匙的状态,搜索的时候再加个状态
            {
                mark[di][dj][t]=next.t;
                q.push(next);
              
        }
    }
    return ans;
}
int main()
{
    int i,j,k,l,si,sj;
    while(scanf("%d%d",&n,&m),n||m)
    {
        k=0;
        memset(e,0,sizeof(e));
        for(i=0;i<n;i++)
        {
            scanf("%s",g[i]);
            for(j=0;j<n;j++)
            {
                if(g[i][j]=='K')
                {
                    si=i;sj=j;
                }
                if(g[i][j]=='S')
                {
                    e[i][j]=k++;  //k只是将每一只蛇区分开。
                }
                for(l=0;l<10;l++)
                {
                    mark[i][j][l]=INF;
                }
            }
        }
        int ans=bfs(si,sj);
        if(ans==INF)
            printf("impossible\n");
        else
            printf("%d\n",ans);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/81835930
今日推荐