A - 前m大的数

还记得Gardon给小希布置的那个作业么?(上次比赛的1005)其实小希已经找回了原来的那张数表,现在她想确认一下她的答案是否正确,但是整个的答案是很庞大的表,小希只想让你把答案中最大的M个数告诉她就可以了。 
给定一个包含N(N<=3000)个正整数的序列,每个数不超过5000,对它们两两相加得到的N*(N-1)/2个和,求出其中前M大的数(M<=1000)并按从大到小的顺序排列。

Input

输入可能包含多组数据,其中每组数据包括两行: 
第一行两个数N和M, 
第二行N个数,表示该序列。 
 

Output

对于输入的每组数据,输出M个数,表示结果。输出应当按照从大到小的顺序排列。

Sample Input

4 4
1 2 3 4
4 5
5 3 6 4

Sample Output

7 6 5 5
11 10 9 9 8
#include<iostream>
#include<cstring>
#include<algorithm>
#include<stdio.h>
using namespace std;
//typedef unsigned long long ull;
const int M=3000*3000/2;
int a[3000+10];
int b[M];//居然不能用 ull ,Memory Limit Exceeded:
//你的程序运行所用的内存太多了,超过了对应题目的限制。
int cmp(int a,int b){
	return a>b;
}
int main()
{
	int n,m;
	while(cin>>n>>m){
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(int i=0;i<n;i++){
			cin>>a[i];
		}
		int k=0;
		for(int i=0;i<n;i++){
			for(int j=i+1;j<n;j++){
				b[k]=a[i]+a[j];
				k++;
			}
		}
		sort(b,b+n*(n-1)/2,cmp);
		cout<<b[0];
		for(int i=1;i<m;i++){
			cout<<" "<<b[i];
		}
		cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41555192/article/details/81813423