Code Formatter(字符串输入)

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Submit Status

Description

Some companies have special requirements for source code format, and it is also good for programmers to keep consistent code style. You are asked to write a simple code formatter for the company to help the poor programmers.

The first thing you need to do is to check whether the source code contains tabs (represented as the escape character '\t'), since different terminals have different ways to display tabs, it's better not to use them, but replace them with spaces. The code formatter should replace each tab of the source code with 4(four) blank spaces.

Then you need to remove trailing spaces of the source file. Trailing spaces are one or more consecutive whitespaces right before the EOL (end of line, represented as the escape character '\n'), and they usually have no meaning in most programming language, so they can be safely removed.

Input

The input contains multiple test cases!

The first line is an integer N indicating the number of test cases. Each test case is the source which contains not more than 100 lines given to you to format. A single line containing only "##" marks the end of a test case.

Output

For each test case, output a log of the formatter in two lines of the following format:

#A tab(s) replaced #B trailing space(s) removed Where #A is the number of tabs replaced and #B is the number of trailing spaces removed.

Sample Input

 2
include <stdio.h>

int main()
{
	int a,b;
	while(scanf("%d %d",&a, &b) != EOF) 
		printf("%d\n",a+b);             
        
}
##

##

Sample Output

4 tab(s) replaced
22 trailing space(s) removed
0 tab(s) replaced
0 trailing space(s) removed

Note

In order to show the whitespaces precisely, all the characters in sample input are underlined. They are not the underscore character.

题意:输出题目有多少个tab键和末尾的空格数。

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int n;
    cin>>n;
    
    char str[1000];
    getchar();
    while(n--)
    {
        int tab=0;
        int ans=0;
        int trail=0;
        while(gets(str))
        {
            if(strcmp(str,"##")==0)
                break;
            int trail=0;
            for(int i=0; i<strlen(str); i++)
            {
                if(str[i]=='\t')
                {
                    tab++;
                    trail+=4;
                    continue;
                }
                if(str[i]==' ')
                {
                    trail++;
                    continue;
                }
                trail=0;

            }
            ans+=trail;
        }
        cout<<tab<<" tab(s) replaced"<<endl;
        cout<<ans<<" trailing space(s) removed"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42671353/article/details/81877282