杭电 6027 Easy Summation

题目链接:点我
Problem Description
You are encountered with a traditional problem concerning the sums of powers.
Given two integers n and k. Let f(i)=ik, please evaluate the sum f(1)+f(2)+…+f(n). The problem is simple as it looks, apart from the value of n in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7.

Input
The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
Each of the following T lines contains two integers n(1≤n≤10000) and k(0≤k≤5).

Output
For each test case, print a single line containing an integer modulo 109+7.

Sample Input
3
2 5
4 2
4 1

Sample Output
33
30
10

照着题意模拟就行,不过在求数的次方数不要直接用pow,数大的话直接会溢出的

#include<iostream>
#include<cstdio>
#include<algorithm>
const int mod=1e9+7;
typedef long long ll;
using namespace std;
int main(){
    int n,t,a,b;
    ll s,sum;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&a,&b);
        sum=0;
        for(int i=1;i<=a;i++){
            s=1;
            for(int j=0;j<b;j++){
                s*=i;
                if(s>mod)
                s=s%mod;
            }
            sum+=s;
            if(sum>mod)
                sum=sum%mod;
        }
        printf("%lld\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37774171/article/details/81980341