C - Friend-Graph

It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team. 
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team. 
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team. 

Input

The first line of the input gives the number of test cases T; T test cases follow.(T<=15) 
The first line od each case should contain one integers n, representing the number of people of the team.(n≤3000n≤3000) 

Then there are n-1 rows. The iith row should contain n-i numbers, in which number aijaijrepresents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends. 

Output

Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”. 

Sample Input

1
4
1 1 0
0 0
1

Sample Output

Great Team!

(注意这里的数组必须用作 bool,否则会内存超限,这个地方坑死了) 

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iomanip>
using namespace std;
bool a[3000+5][3000+5];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,i,j,k,flas1=0,flas2=0;
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            for(j=1+i; j<n; j++)
            {
                int x;
                scanf("%d",&x);
                a[i][j]=a[j][i]=x;
            }
        }
        for(i=0; i<n; i++)
        {
            for(j=i+1; j<n; j++)
            {
                for(k=j+1; k<n; k++)
                {
                    if(a[i][j]==0&&a[j][k]==0&&a[i][k]==0)
                    {
                        flas1=1;
                        break;
                    }
                    if(a[i][j]==1&&a[j][k]==1&&a[i][k]==1)
                    {
                        flas2=1;
                        break;
                    }
                }
                if(flas1||flas2)break;
            }
            if(flas2||flas1)
                break;
        }
        if(flas1||flas2)printf("Bad Team!\n");
        else printf("Great Team!\n");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81989923