【洛谷】P1308 统计单词数(字符串流)

题目链接

题目描述

一般的文本编辑器都有查找单词的功能,该功能可以快速定位特定单词在文章中的位置,有的还能统计出特定单词在文章中出现的次数。

现在,请你编程实现这一功能,具体要求是:给定一个单词,请你输出它在给定的文章中出现的次数和第一次出现的位置。注意:匹配单词时,不区分大小写,但要求完全匹配,即给定单词必须与文章

中的某一独立单词在不区分大小写的情况下完全相同(参见样例1 ),如果给定单词仅是文章中某一单词的一部分则不算匹配(参见样例2 )。

输入输出格式

输入格式:

共 2 行。

第 1 行为一个字符串,其中只含字母,表示给定单词;

第 2 行为一个字符串,其中只可能包含字母和空格,表示给定的文章。

输出格式:

一行,如果在文章中找到给定单词则输出两个整数,两个整数之间用一个空格隔开,分别是单词在文章中出现的次数和第一次出现的位置(即在文章中第一次出现时,单词首字母在文章中的位置,位置从 00 开始);如果单词在文章中没有出现,则直接输出一个整数 -1−1 。

输入输出样例

输入样例#1: 复制

To
to be or not to be is a question

输出样例#1: 复制

2 0

输入样例#2: 复制

to
Did the Ottoman Empire lose its power at that time

输出样例#2: 复制

-1

注意文章中单词间的空格数可能不止一个。

AC代码:

#include<iostream>
#include<sstream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<vector>
#include<cmath>
#include<stack>
using namespace std;
string to_lower(string a)//转化为小写 
{
	for(int i=0;i<a.length();i++)
	if(a[i]>='A'&&a[i]<='Z') a[i]+=32;
	return a;
}
int main()
{
	string str,input;
	cin>>str;//要查找的单词 
	getchar();
	str=to_lower(str);
	getline(cin,input);
	input=to_lower(input);
	stringstream ss(input);
	
	int num=0,pos=-1,i=0;
	string temp;
	while(1)
	{
		if(ss.peek()==' ') 
		{
			i+=1;ss.get();continue;
		}
		else if(ss.peek()==EOF) break;//到达末尾
		
		ss>>temp; 
		if(temp==str)
		{
			if(pos==-1)  pos=i;//第一次出现的位置
			num++;
		}
		i=i+temp.length();
	}
	if(pos==-1) cout<<"-1";
	else cout<<num<<' '<<pos;
}

猜你喜欢

转载自blog.csdn.net/qq_40889820/article/details/82085191
今日推荐