Double Queue

Double Queue

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1455    Accepted Submission(s): 733


 

Problem Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

 

 

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.
 

 

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.
 

 

Sample Input

 

2 1 20 14 1 30 3 2 1 10 99 3 2 2 0

 

Sample Output

 

0 20 30 10 0

题意:四种操作:输入1:输入一个编号为id的顾客他的优先级为p;

                             输入2:输出优先级最高的顾客id,并从数据中去除 ;

                             输入3:输出优先级最低的顾客id,并从数据中去除 ;

                             输入0:结束;

AC代码:

#include<cstdio>
#include<set>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
	int id,p;
	bool operator <(const node &t ) const
	{
		return p<t.p;
	}
};
int main()
{
	set <node> s;
	set <node> ::iterator it;
	int op;
	while(~scanf("%d",&op)&&op)
	{
		node e;
		switch(op)
		{
			case 1:
				{
				    cin>>e.id>>e.p;s.insert(e);break;
				}
			case 2:
				{
					if(s.empty())
					{
						puts("0");break;
					}
					it=--s.end();printf("%d\n",it->id);s.erase(it);break;
				}
			case 3:
			    {
				   	if(s.empty())
					{
						puts("0");break;
					}
					it=s.begin();printf("%d\n",it->id);s.erase(it);break;
			    }
		}
	}
}

猜你喜欢

转载自blog.csdn.net/qq_42709126/article/details/81543374